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About This Document
This document describes how to connect your cloud vApps to your labs and how to conduct
tenant administration tasks using the VMware® Learning Platform™ administration user
interface.

Audience
The primary audience for this guide is tenant administrators.

Revision History
Revision #
1.0

Release Date
September 19, 2018

1.1

October 8, 2018

1.2

October 16, 2018

1.3

November 13, 2018

1.4

November 27, 2018

1.5

January 14, 2019

Updates
• Update Cloud Org
VDC Capacity action
• Security>User
Messages option
• Create vApp
Templates option
• Account List Bulk
Upoload-support for
Content Creator role.
• Select Cloud Org vDC
to be Drained of
Prepops. Impacts both
the Admin UI’s Cloud
Org vDC List and the
vApp Template List.
• Lab List supports the
Lab Vms column.
• Edit Tenant form,
General Options
section, includes an
Auto Run
Compatibility
Checker.
• Show Default
Welcome Tips.
• Support for an LMS
that does not include a
field to add custom
parameters.
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Administration Prerequisites
Before you begin your tenant administration tasks, you must meet certain prerequisites.

Cloud Resources and Administrator Credentials
You must have procured cloud resources and received tenant administrator credentials from the
VMware Learning Platform support staff. Typically, the VMware Learning Platform support
staff sends you an email containing your username and password soon after your organization
purchases a VMware Learning Platform tenant.

Supported Browsers and Environments
You access VMware Learning Platform through a browser. VMware Learning Platform supports
the following browsers:
• Internet Explorer version 10 and above
• Firefox version 13 or above
• Chrome version 18 or above
• Safari version 6.0 or above
Note: Browser settings should accept cookies, run JavaScript and allow web sockets.

Supported Versions of VMware vCloud Director
To deploy virtual machine labs, VMware Learning Platform requires VMware vCloud Director
Version 5.5 or higher.

Instructional Content
Instructional content (manuals) for your labs must already exist. You can import an existing
manual using the Content Engine user interface.
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Delivering a Lab
To deliver a VMware Learning Platform lab, you must, at minimum, complete the following
tasks:
1.
Connect cloud resources to VMware Learning Platform. See Creating a Cloud Org.
2.
Create a deployment pool. See Creating a Deployment Pool.
3.
Create a lab. See Creating a LabCreating a Lab.
4.
Create a catalog to contain the lab. See Creating a Catalog.
5.
Create users for the lab. See Creating User Accounts.
6.
Import a lab instructional manual. See Content Editor Guide.
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Logging into and Selecting a Tenant
Once you have met the administration prerequisites, you are ready to get started. VMware
Learning Platform provides a tenant administration user interface (Admin UI) that allows you to
manage a VMware Learning Platform tenant or tenants.

About Tenants
A tenant is a company or institution (or a department within a company or institution) that has
purchased access to VMware Learning Platform. The VMware Learning Platform technical staff
provisions your tenant(s) based upon information provided by your organization. You (the tenant
administrator) can have administrative rights to one or more tenant.

Logging Into a Tenant
To log into VMware Learning Platform:
1. Direct your browser to: https://core.vmwarelearningplatform.com
2. Enter your login credentials. Once you successfully login, the Admin UI opens.

Selecting a Tenant
An admin can have access to multiple tenant. Accordingly, the Admin UI includes a tenant
selector:
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Working with Admin UI Lists
Manipulating Lists
You have flexibility in manipulating Admin UI lists such as lab lists, cloud lists and task lists:
• Click the Gear icon to open a pull-down list of display options. You can filter what
headings a list displays using the enable/disable checkboxes. The following example
shows pull-down list settings for a Lab List.

•

Conduct a search. The following example shows the Search Labs of the Lab List:

•

Reorder a list by a “drag/drop” action.

Utilizing Warnings/Errors Column
Lists include a column for warnings/errors to alert you to an issue that exists with an item in the
list. You can click on a warning/error icon to get information about the issue as shown in the
following example Lab List (“Warning, Lab does not have a manual”):
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Working with the Cloud Org List
Note the following about how the system manages clouds:
• VMware Learning Platform considers “deployment” to be the action of creating a new
vApp in the cloud, either as a prepop or as an on-demand creation. It considers
“assignment” to be the action of assigning an existing prepop to an entitlement that is
being started for the first time or is having its vApp reset. These settings specify a
baseline for determining whether the VMware Learning Platform can use the cloud for
the action. If an action is disabled for this cloud org, then the org will not be used for this
action regardless of any other settings. If the action is enabled for this cloud, then the
settings on the vDC and/or template will be used to determine if the action can proceed.
• VMware Learning Platform determines whether a cloud is enabled for a specific action
by following a series of steps, in a specific order, where each step checks one setting. If
the setting means the cloud is disabled for the action, then the cloud is disabled for that
action. Only if all steps are completed, with no step indicating that the action is disabled,
will VMware Learning Platform consider the action enabled. Thus, if an early step in the
process indicates that an action is disabled, then no subsequent step in the process can
make the action enabled.

Creating a Cloud Org
As part of creating labs for your tenant, you first must connect your organization’s VMware
vCloud Director to VMware Learning Platform. You do so by creating a cloud org. To create a
cloud org:
1. Click Cloud Management>Clouds to display the Cloud Org List.
2. On the Cloud Org List, click Create Cloud Org. The Create Cloud Org form opens with
the Cloud Org Info tab active. Enter your cloud org details:

a. Tenant Assignment and Tenant Deployment: Both apply only apply to the current
tenant and will not affect other tenants using this cloud org. Their settings only
have meaning if Enabled has been set to true and the corresponding activity
setting is also true (for example, Tenant Assignment only has meaning if
Assignment has been set to true). Both can be used to disable deployments or
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b.

c.

d.

e.
f.

g.
h.

assignments for a specific tenant, without affecting the tenant settings for other
tenants.
Tenant Maintenance Mode: Enables/disables tenant maintenance mode for the
selected cloud org(s). This field is tenant-specific, that is it affects only your
tenant. This field is useful when you do not want activity in the selected cloud org
(for example, due to problems/issues or an upgrade).
Org Name: Name of your organization. The Org name is case sensitive.
Note: If you do not know your org name, go to next section “Finding Org
Names”.
Host Name: Hostname for your organization’s VMware vCloud Director
(Example: abc-vclass1.xyzedu.com).
Note: VMware Learning Platform does check to confirm that the host you
specified has a certificate. However, VMware Learning Platform does not validate
the certificate.
Org Admin: Username of the tenant’s administrator.
Password: Password for administrator.
Note: When a cloud login attempt fails, VMware Learning Platform will not
attempt another login for one minute. Such cloud login failures can occur in many
cases, for example when you (the tenant admin) perform administrative tasks or
when an end user tries to take a lab. Most cloud login failures trigger a
notification to the tenant. VMware Learning Platform throttles such notifications
such that it only sends one notification within any ten-minute period. Multiple
login failures within this ten-minute period do not trigger multiple notifications.
VMware Learning Platform enforces both these limits on a per-node instance and
typically runs multiple nodes. Thus, it is possible that it will send more than one
notification in a ten-minute period if, for example, different nodes experience a
failure during that time.
API Version: Version of cloud you intend to use (Example: VCloud_API_5_1).
Display Name: (Optional) Name which will display in the Cloud Org List.
Note: Enable display of the name by clicking on
(gear icon) on the Cloud Org
List and checking “Display Name”.

TENANT ADMINISTRATOR REFERENCE GUIDE /13

Tenant Administrator Reference Guide

3. Once you have entered the details, click Create. The Cloud Org VDCs tab opens. The
following is an example tab that includes example data:

In order to deploy your template as a vApp, VMware Learning Platform must know of an
organization’s virtual data center (vDC) in which to deploy it and an organization vDC
network to connect it. VMware Learning Platform automatically fills-in all the fields for
you. However, you must enable (set to True) at least one organization virtual database so
that VMware Learning Platform can deploy the vApp template.
4. Click Update. The Cloud Catalogs tab opens.

5. In the Cloud Catalogs tab, enable (True) at least one catalog you want VMware Learning
Platform to use. A catalog is a collection of vApp templates. Enabled means that the
templates contained in a catalog are available to VMware Learning Platform. VMware
Learning Platform needs access to templates to build a lab.
6. Click Update. You have now finished connecting your organization’s VMware vCloud
Director to VMware Learning Platform.
Note: Until your tenant includes a cloud org, it will not have access to any vApp
templates. Having a cloud org, accomplishes the following:
o Enables your organization’s virtual data center(s) so the system can deploy
vApp templates
o Enables a catalog so that the system can access the vApp templates contained
in that catalog

TENANT ADMINISTRATOR REFERENCE GUIDE /14

Tenant Administrator Reference Guide

Finding Org Names
If you are unsure of your org name, go to the Virtual Cloud Director and check your cloud.

To check your organization full name:
1. On the Virtual Cloud Director, go to the Administration tab.
2. On the Administration tab, expand Settings.
3. Within Settings, click General and note the Organization name, which in the example is
“Rainpole”.

Setting Cloud Org List Fields
Fields on the Cloud Org List that affect all tenants can only be set by VMware Learning Platform
technical staff. You (the tenant admin) can set fields that affect only your tenant.
1. Click Cloud Management>Clouds. The Cloud Org List opens.
2. Click to select fields you would like to display as shown in the following example:

•

Enabled, Deployment, Assignment, Tenant Deployment, and Tenant Assignment: These
fields control deployment and assignment for the selected cloud org. Deployment means
deploying a new vApp as either a prepop or as an on-demand deployment. Assignment
means assigning an existing prepop to an entitlement once a user starts the lab. Note the
following:
o Enabled: Indicates whether a cloud org can be used. If set to True, then the system
will not use the cloud org for deployments or assignments regardless of any other
settings. VMware Learning Platform technical staff enables/disables this field.
o Deployment and Assignment: Both are active only if Enabled has been set to
True. These fields enable/disable assignment or deployment for all tenants. If both
are set to False, then the result is the same as setting Enabled to False. VMware
Learning Platform technical staff enables/disables these fields.
o Tenant Assignment and Tenant Deployment: Both apply only apply to the current
tenant and will not affect other tenants using this cloud org. Their settings only
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•

•

•

•

•

•

have meaning if Enabled is set to True and the corresponding activity has been set
to True. For example, Tenant Assignment only has meaning if Assignment has
been set to True. You can use both to disable deployments or assignments for a
specific tenant without affecting the tenant settings for other tenants.
Example 1: To enable assignment for a cloud org, Enabled, Assignment and
Tenant Assignment must be set to True. If any of those are set to False, then the
system cannot use the cloud org for assignment.
Example 2: If a cloud org is to be taken out of service, then it could be enabled
only for assignments but not for deployments. Thus, the system could not make
new deployments to the cloud org. However, the system would still allow using
existing prepops on that cloud org.
Example 3: If a cloud org is to be brought online, then it could be enabled for
deployments but not assignments. Thus, starting to deploy prepops to the cloud
org would be valid. However, the system would not use the prepops for labs until
the cloud org has officially been made available.
Tenant Maintenance Mode: Enables/disables tenant maintenance mode for the selected
cloud org(s). This field is tenant-specific, that is it affects only your tenant. This field is
useful when you do not want activity in the selected cloud org (for example, due to
problems/issues or an upgrade).
Maintenance Mode: Enables/disables maintenance mode for the selected cloud org(s) and
affects all tenants. If set to True, then the system will not deploy any new vApps in the
cloud org and will not use any existing vApps from the cloud org. Only VMware
Learning Platform technical staff enables/disables this field. This field is useful to disable
a cloud org for maintenance (for example, for an upgrade or a restart).
Sync vApp Templates: Syncs the latest list of templates in the available catalogs from the
cloud and updates the record by adding or deleting as necessary. These are the templates
available for use in the deployment pools, which in turn the system uses to indicate which
vApps can be used (for example, that can be used by labs).
Delete Prepops without templates: Removes vApp records that regard vApps that should
be available in the cloud, but for some reason are not available. (In some cases, the
vApps had been deleted outside of VMware Learning Platform.) The system does not
consider these prepops available and thus will never use them. However, the system does
keep a record of them until an admin “deletes prepops without templates”.
Remove from tenant: Deletes the org. Because an org can be shared across tenants, no
single tenant can delete it. This option effectively deletes the org as far as the current
tenant is concerned, but the actual records will not get deleted completely until there are
no tenants still using this org.
Create vApp Templates: Opens a vCD login page. This option is only visible for a
VMware Learning Platform-provided cloud. You can select the cloud, then select the
Create vApp Templates option to open a vCD login page. Once you log in, you can use
vCD to author a vApp. Procedures to author a vApp in vCD are documented in the VLP
Getting Started guide.
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Submitting Cloud Org List Actions
The Cloud Org List includes an actions pull-down.
1. Select a cloud org.
2. Click Actions to open the pull-down.
3. Click Submit to complete the action.

•
•
•
•

Remove from Tenant: Removes the selected cloud org from the tenant.
Delete Prepops without templates: Deletes and undeploys from the cloud, those prepops
having no vApp template. This action allows the system to properly maintain the cloud.
Sync vApp Templates: Syncs the selected vApp template.
Update Cloud Org VDC capacity: Updates the record of cloud usage (cloud capacity) for
the selected cloud org. The system updates capacity for each VDC in the cloud org.
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Working with the Cloud Org VDC List
You can work with the Cloud Org VDC List (Cloud Management>Cloud oVDCS) much like
you can with the Cloud Org List. The Cloud Org VDC List allows you to enable/disable at the
cloud org VDC level. Fields that affect all tenants can only be set by VMware Learning Platform
technical staff. You (the tenant admin) can set fields that affect only your tenant.

•

Enabled, Deployment, Assignment, Tenant Deployment, and Tenant Assignment: These
fields control deployment and assignment for the selected cloud org VDC. Deployment
means deploying a new vApp as either a prepop or as an on-demand deployment.
Assignment means assigning an existing prepop to an entitlement once a user starts the
lab. Note the following:
o Enabled: Indicates whether a cloud org VDC can be used. If set to True, then the
system will not use the cloud org VDC for deployments or assignments regardless
of any other settings. VMware Learning Platform technical staff enables/disables
this field.
o Deployment and Assignment: Both are active only if Enabled has been set to
True. These fields enable/disable assignment or deployment for all tenants. If both
are set to False, the result is the same as Enabled being set to False. VMware
Learning Platform technical staff enables/disables these fields.
o Tenant Assignment and Tenant Deployment: Both apply only apply to the current
tenant and will not affect other tenants using this cloud org VDC. Their settings
only have meaning if Enabled is set to True and the corresponding activity is set
to True. For example, Tenant Assignment only has meaning if Assignment has
been set to True. You can use both to disable deployments or assignments for a
specific tenant without affecting the tenant settings for other tenants.
Example 1: To enable assignment for a cloud org VDC, Enabled, Assignment and
Tenant Assignment must be set to True. If any one of these is set to False, then
the system cannot use the cloud org VDC for assignment.
Example 2: If a cloud org VDC is to be taken out of service, then the cloud org
VDC could be enabled only for assignments but not for deployments. Thus, the
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•

•

•

system could not make new deployments to the cloud org VDC. However, the
system would still allow using existing prepops on that cloud org VDC.
Example 3: If a cloud org VDC is to be brought online, then it could be enabled
for deployments but not assignments. Thus, starting to deploy prepops to the
cloud org VDC would be valid. However, the system would not use the prepops
for labs until the cloud org VDC has officially been made available.
Tenant Maintenance Mode: Enables/disables tenant maintenance mode for the selected
cloud org VDC(s). This field is tenant-specific, that is it affects only your tenant. This
field is useful when you do not want activity in the selected cloud org VDC (for example,
due to problems/issues or an upgrade).
Maintenance Mode: Enables/disables maintenance mode for the selected cloud org
VDC(s) and affects all tenants. If set to True, then the system will not deploy any new
vApps in the cloud org VDC and will not use any existing vApps from the cloud org
VDC. Only VMware Learning Platform technical staff enables/disables this field. This
field is useful to disable a cloud org VDC for maintenance.
Drain All Prepops: Drains all prepops from the selected cloud org vDC but retains
prepops for the template in other vDCs.
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Working with Shadow Management
In VMware vCloud Director, if you deploy a vApp that resides in a different storage pool other
than where it actually had been deployed, then vCD first deploys a “shadow copy” in the new
storage pool. The vCD then deploys a vApp from that shadow copy which is essentially a
double-deployment that could take a lengthy amount of time leaving the end-user waiting.
The Admin UI includes a shadow management feature that allows a tenant administrator to see
where shadow copies reside in the various storage pools. The tenant admin can pre-deploy a
shadow to pools that do not already have a copy of that lab thus reducing the wait time for the
end-user.
To open the Cloud Shadow page:
1. Click Cloud Management>Cloud Shadow. The Cloud Shadow page opens.

2. Select the Cloud org(s) you want to display. As shown in the following example, the
system displays where shadow copies reside in the various storage pools:

3. Optionally, you can click Refresh Shadow Information to run a shadow update only for
the cloud(s) you selected. This cloud-specific shadow update avoids having to updating
all clouds.
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Working with Cloud System Credentials
If you want a cloud to use cloud shadow information, use the Cloud System Credentials option to
add system credentials for that cloud. You can create a new credential or view existing ones. You
cannot edit or delete the existing credentials.

Creating a System Credential
To create a new credential record:
1. Click Cloud Management>Cloud System Credentials to open the
CloudSystemCredential List.

2. Click Create CloudSystemCredential to open the Create form.

3. Enter the Basic Info for your new credential:
a. Select a hostname
b. Enter your username.
c. Enter your password.
d. Enable the credential.
e. Enter note about the credential.
4. Click Create.
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Working with the CloudVapp List
You can use the CloudVapp List (Cloud Management>Cloud Vapps) to view information
about and take actions upon the cloud vApps that VMware Learning Platform is using.

Working with the Disown CloudVapp Action
The Disown CloudVapp action permanently removes the selected vApp from VMware Learning
Platform but retains it (unchanged) in the cloud. This action is useful in cases where you think
there is a problem with how a vApp is functioning in the cloud. In such a case, you can “disown”
the vApp. Thus, while cloud support personnel determine what went wrong with the vApp, your
tenant is not impacted by the problematic vApp.

Working with the Delete CloudVapp Action
The Delete CloudVapp action deletes the selected vApp. This action useful to delete a corrupted
prepop. The action results in the vApp being removed from both VMware Learning Platform and
the cloud.
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Working with the Deployment Pool List
A deployment pool is a collection of one or more vApp templates and is specific to a single
tenant. Note the following regarding the relationship between labs and deployment pools:
• When you create a lab, you must select an existing deployment pool to associate with that
lab.
• A deployment pool includes virtual machine metadata. The metadata primarily concerns
the username, password, notes and a flag for each virtual machine within the vApp(s)
associated to the deployment pool.
• Any lab that does not override the virtual machine metadata values in its associated
deployment pool gets those values.

Creating a Deployment Pool
Entering Basic Info
Because of the deployment pool/lab relationship, it is best to configure a deployment pool before
creating a lab. To create a deployment pool:
1. Click Cloud Management>Deployment Pools. The Deployment Pool List opens.
2. Click Create Deployment Pool. The Create Deployment Pool form opens with the Basic
Info tab current.

3. Enter details about the deployment pool you want to create:
a. Name: Give the deployment pool a descriptive name.
b. Description: Enter some descriptive text about the deployment pool.
c. Initial vApp Template: Select a vApp template from the Manage List View pulldown. The vApp template you select will be “contained” in the deployment pool
you are creating.
Note: When you are creating a deployment pool, you can only select a single,
“primary” vApp template. However, you can later add additional vApp templates.
The role of a primary vApp template is to enforce identical structure. That is, all
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templates in a pool must have the same number of virtual machines, same
operating system, same CPU and memory, same virtual machine names and so
on. The system starts with one template (primary) and checks any template being
added to the pool to ensure it matches the template(s) currently in the pool.
4. Click Create. The system creates your deployment pool and opens the Edit vApp
Templates tab.

Editing vApp Templates
The Edit vApp Templates tab includes options for setting prepop values. Some vApps are
hundreds of gigabytes in size and thus it could take time for a lab to deploy. To create a better
user experience, VMware Learning Platform utilizes the prepop feature. The prepop feature
deploys an instance of a lab ahead of user demand and leaves it running. Thus, when a user
requests an instance of that lab, VMware Learning Platform connects that user to an already
running copy in a matter of seconds, and then queues up another deployment of a pre-pop for
future.
1. Use the tab to edit the vApp template you chose (the primary vApp template) or to
add/remove templates.

o + Add/Remove vApp Templates: Displays a list of available vApps. You can add
a vApp template(s) to the deployment pool in addition to the primary vApp
template. You can also delete vApps from the deployment pool. Note the
following:
▪ All vApp templates must have an identical structure. Thus, any vApp
template that you add becomes part of a collection of a vApp templates.
▪ There is no difference between a primary and an additional vApp template
beyond the primary’s role in enforcing identical structure.
▪ If you add vApp templates, then the deployment pool aggregates vApp
template values such as Refill At and Fill Up.
Note: If you include the same vApp template in multiple deployment
pools and later edit the values of that shared vApp template, then each
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deployment pool that shares the vApp template recalculates the aggregate
values.
▪ System will not allow you to remove all the vApp templates from a
deployment pool when there are one or more entitlements for labs that use
the pool.
▪ System will not allow you to change all the templates in a pool with a
single edit when there is an entitlement for a lab that uses the pool. That is,
you cannot remove all existing templates and then add new ones. You can
however, make two edits: First add the new templates to the pool; next
remove the old templates (you cannot do this in a single edit).
o Enabled: Enables/disables the vApp template. For example, if there are two
templates and one is disabled, then the disabled template will not get any prepops.
o Cloud Enabled: Displays the status (enabled or disabled) of the Cloud Org or
Cloud Org VDC.
o Refill At: Sets value for the least amount of available prepops. If the number of
available prepops goes below the Refill At value, then the system deploys prepops
(refills) until the Refill At value is met.
o Fill Up: Sets value to reach (fill up) for the number of prepops to be deployed.
o Prepops: Sets the current number of prepops available for the vApp template. If
you adjust this number, it will add/remove prepops from the vApp template. A
warning message appears if a deployment pool is disabled. A disabled
deployment pool cannot deploy prepops.
o VM Equality Check: If enabled, then the system runs a check of the virtual
machines included in the template to determine that they all have the same basic
structure. The check ensures the virtual machines all have the same names, the
same number of CPUs, the same memory assignment and the same guest
operating system.
2. Click Update to update the deployment pool. The VM Metadata tab opens.

Editing VM Metadata
1. Use the VM Metadata tab to edit the metadata of the deployment pool.

o Use Individual VM Power On Settings: If enabled, then VMware Learning
Platform controls the powering on of VMs according to the setting of the Power
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On VM When Lab Starts option (described below). If not enabled, then the cloud
controls the powering of VMs. Cloud powering settings are determined outside
VMware Learning Platform.
Note: This option only regards the delegation of VM power on operations either
to the cloud or to VMware Learning Platform. Prepop deployment always
delegates power on operations to the cloud.
o Initial Console: If enabled, labs associated to the deployment pool will use the
virtual machine as its initial console.
o Click > to edit metadata.

▪

▪

Visible: If enabled, then the virtual machine is visible in the lab. (If not
enabled, then VMware Learning Platform will not have console
connection.) For example, consider a lab with 12 virtual machines. You
can use the Visible option to have the lab end user have access to only a
single virtual machine.
Note: If you select only one virtual machine to be visible to the end user,
then VMware Learning Platform will hide the console chooser that is
normally on the left-hand side of the console screen of the lab console.
Power On VM When Lab Starts: Specifies that the VM in the vApp
should be powered on when the entitlement starts. If enabled, then the
system can more efficiently determine the power state of the VM and thus
reduce the time it takes to start the lab. Note the following:
• If all the VMs in a deployment pool or lab are marked as being
powered on, then the system will start the vApp instead of the
individual VMs which delegates the powering-on operation to the
cloud. This delegation means that the VMs in the vApp will be
powered on as configured for the template in the cloud. Thus, the
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system will observe any configured power up order, pauses or
other tasks as configured in the cloud.
• If the VM marked as the initial console is not marked to be
powered on at start (and other VMs are marked for power on), then
the system will display a warning in the Lab List.
▪ Allow Console Resize: If enabled, then a lab user can manually resize the
lab console.
▪ Automatic Console Resize: If enabled, then the system will automatically
scale a lab console so that it fits the available space.
Note: If both Allow Console Resize and Automatic Console Resize are
enabled, then the system will initially size the lab console but the lab user
will still be able to resize it manually.
▪ Username: You can specify a username specific to the virtual machine.
▪ Password: You can specify a password specific to the virtual machine.
▪ Notes: Notes an end user might need when interacting with a virtual
machine. For example, you could include license keys in a note. Notes
supports rich text/HTML information on the virtual machine for the lab.
VMware Learning Platform displays the notes when an end user clicks the
Notes option on the lab console toolbar.
2. Click Update to update the deployment pool.

Exporting Deployment Pool Configuration Information
The Deployment Pool List includes an option that you can use to export full deployment pool
configuration information including the relationship between lab, deployment pool and vApps.
Note: The vApp Template List also includes the same option.

1. Click
. A form opens that provides a choice between exporting to a
CSV or Excel file.
2. Click CSV or Excel. The system opens a form that provides a choice between saving or
opening the file. The following is an example Excel file:
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Naming Prepops
The Deployment Pool List includes a Prepop Naming Template option. It allows you to specify
the pattern the system will use to generate a name for a prepop. By default, the system uses a
single, static pattern for the naming.

Naming vApps
The Deployment Pool List includes a vApp Naming Template option and is similar to the Prepop
Naming Template option. The system uses the vApp Naming template to generate a name for an
assigned vApp (either an assigned prepop or an on-demand deployment). It specifies the fixed
text (outside the square brackets) and the variable names (inside the square brackets) from which
the system generates the name by replacing the variables with their current values.
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Editing Existing Deployment Pools
You can edit an existing deployment pool from the Deployment Pool List.
1. Click Cloud Management>Deployment Pools. The Deployment Pool List opens.
2. Click
along the deployment pool you want to edit. A pull-down opens that
includes the following options:

•
•
•
•
•
•
•
•
•

Edit Deployment Pool: Opens a three-tab editing form. The Edit Deployment Pool tab is
current.
Edit vApp Templates: Opens a three-tab editing form. The Edit vApp Templates tab is
current. This is the tab described in the section “Editing vApp Templates”.
Edit VM Metadata: Opens a three-tab editing form. The VM Metadata is current. This is
the tab described in the section “Editing VM Metatdata”.
Sync Prepops: Sends a start request for all the prepops currently deployed. The start
request does nothing if a prepop already exists. It creates a prepop if one does not exist.
Note: Use this option only if you suspect there are prepops in an invalid state.
Drain Prepops: Undeploys all prepops and thus drops the number of deployed prepops to
zero.
Clear Errors: When a prepop fails to deploy, VMware Learning Platform marks it as an
error and shows the count of errors. Clearing the errors marks the database record for the
error as cleared and drops the current count of errors to zero.
Fill Up Option: Deploys enough prepops to equal the Fill Up value set within the
deployment pool.
Set To Refill At: Deploys prepops until the Refill At value is met.
Remove all vApp Templates: Removes all vAppTemplates and restructures the
Deployment Pool. This action will delete all lab VM metadata and deployment pool VM
metadata currently associated with the Deployment Pool. The system will not allow you
to remove all the vApp templates from a deployment pool when there are one or more
entitlements for labs that use the pool.
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•

More Details: Opens the View Deployment Pool page. It displays details about the
selected pool similar to the following example:

•
•
•
•
•
•
•
•
•
•
•
•

Name: Name of the deployment pool.
Description: Descriptive text of the deployment pool.
Refill At: Value for the least amount of available prepops. If the number of
available prepops goes below the Refill At value, then the system deploys prepops
(refills) until the Refill At value is met.
Fill Up: Value to equal (fill up) - amount of prepops that should be deployed.
Available: Number of prepops ready to use for taking a lab.
Provisioning: Refers to the number of vApp templates being “booted up” but not
yet ready to use for taking a lab.
Error Count: Number of prepops that failed to deploy.
Hit: Number times users got pre-pops when requested.
Miss: Number of times users got a full deployment of a lab and thus had to wait.
Labs: List of labs included in the deployment pool.
VMs: List of virtual machines included in the deployment pool.
Vapp Templates: List of vApp templates included in the deployment pool.

Mass Actions
The Deployment Pool List includes a mass action pulldown that you can use to perform an action
on all deployment pools. The pulldown includes the Clear Errors option.

When a prepop fails to deploy, VMware Learning Platform marks it as an error and shows the
count of errors. The Clear Errors option clears all errors, for all the deployment pools listed and
drops the current count of errors to zero.
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Working with the vApp Template List
A vApp is a container that can contain one or more virtual machines. vApp templates ensure that
virtual machines are consistently configured across an entire organization. The vApp Template
List provides many options to manage your tenant’s vApp templates.

Enabling/Disabling Display of Statistics
You can use the gear icon pull-down on the vApp Template List to enable/disable the display of
vApp template-related statistics.

Note: Average Prepop Deploy Time is the average deploy time for prepops, in seconds, based
upon a seven-day rolling time. A value of 0.0 means that the system does not currently have an
average deploy time available.

Editing the Selected vApp Template
Click

along the vApp template you want to edit. A pull-down opens:
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•

Edit vApp Template: Opens a form for the selected vApp template with the Edit vApp
Template tab current.

o Enabled/disabled (the vApp template): If not enabled, then the vApp template
cannot deploy prepops or an on-demand lab. This field is useful when you want to
disable prepop deployment for a vApp template hosted in a particular cloud. For
example, you might have a vApp hosted in a cloud located in the United States
and a clone of that vApp hosted in Europe. In such cases, you might want to
deploy prepops only in the vApp hosted in the United States but not in Europe.
o Fixed Size: If the Fixed Size field is enabled, then the Refill At and Fill Up values
do not display. Instead the Pool Size value displays. The Pool Size value, sets
Refill At and Fill Up values to the Pool Size value. Most importantly, if Fixed
Size is enabled, then the system will always keep the number of running vApps
equal to the pool size limit value. Thus, the Fixed size field allows a tenant admin
to ensure that the number of running vApps is constant, regardless of the system
refilling prepops. Example Scenario: If the tenant admin were to set the vApp
template to a pool size of 10, then:
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▪
▪
▪

System will deploy 10 vApps and set Refill At and Fill Up to 10.
If an end user were to then start a lab, the system would utilize one of the
10 vApps and assign the vApp to the end user’s entitlement.
vApp template would continue to have 10 running vApps. If additional
end users continue to start labs and utilize all the deployed vApps from the
fixed size pool, then upon an 11th entitlement, the system would return an
error.

o Refill At: Value for the least amount of available prepops. If the number of
available prepops goes below the Refill At value, then the system deploys prepops
(refills) until the Refill At value is met.
o Fill Up: Sets a value to reach (fill up) for the number of prepops to be deployed.
o Prepops: Sets the current number of prepops available for the vApp template. If
you adjust this number, it will add/remove prepops from the vApp template.
o Concurrent Usage Limit: The maximum number of vApps, for this template, that
the system will allow to be running. If a user starts a lab while below the
concurrent usage limit, then the system will allow the user to start the lab.
However, if a user starts a lab while the concurrent usage limit has been reached,
then the system will not allow the user to start the lab. The concurrent usage limit
increases once a student successfully starts a lab but decreases when a student
ends/exits a lab.
o Placement Algorithm: Specifies the placement algorithm for this vApp template
and overrides the tenant-wide placement algorithm as set in the Edit Tenant page
(within General Options). Placement algorithms are described in the discussion
about the Name of Default Prepop Placement Algorithm option. See the section
“About the Edit Tenant Options”.
o Time To Live (Hours) (0 Implies No Limit): Specifies the amount of time, in
hours, that a prepop can exist before the system deletes it. This field allows you to
specify the amount of time a prepop should be left waiting in the cloud until either
the system assigns it to an entitlement or deletes it.
Note: When the system successfully deploys a prepop, it adds a timestamp to the
database record. By using the timestamp and the value of the template’s “Time to
Live” field, the system calculates when it should delete the prepop. When the time
to delete the prepop arrives, the prepop becomes eligible for recycling. This
recycling will not occur until the next time the job that checks prepop statuses
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•
•
•
•
•
•
•

runs, meaning prepops could continue to “live” past their end of life time by
several minutes.
o Auto-Deploy Replacements For Expired Prepops: If enabled, then the system will
deploy a new prepop each time a prepop has been undeployed because it has
reached its Time To Live limit.
Note: For fixed size pools, auto-redeployment will occur whether this field is
enabled or not.
o Assignment Algorithm: Specifies the assignment algorithm for this vApp
template and overrides the tenant-wide placement algorithm as set in the Edit
Tenant page (within General Options). Assignment algorithms are described in
the discussion about the Name of Default Prepop Placement Algorithm option.
See the section “About the Edit Tenant Options”.
o Assignment Prepop Preference: Specifies the assignment prepop preference for
this vApp template and overrides the tenant-wide prepop preference as set in the
Edit Tenant page (within General Options). Prepop preferences are described in
the discussion about the Name of Default Prepop Placement Algorithm option.
See the section “About the Edit Tenant Options”.
o Prepop Template Name Example: Displays an example of a prepop name that was
generated by means of the pattern used by the system. By default, the system uses
a single, static pattern for the naming.
o Drain Prepops Tab: Opens a tab that lists all the cloud org vDCs having the
template running within them as prepops. This list allows you to select a specific
org vDC to be drained as opposed to draining all prepops.
Sync Prepops: Sends a start request is sent for all the prepops currently deployed. The
start request does nothing if a prepop already exists. It creates a prepop if one does not
exist.
Drain All Prepops: Undeploys all prepops and thus drops the number of deployed
prepops to zero.
Drain Prepops: Opens a tab that lists all the cloud org vDCs having the template running
within them as prepops. This list allows you to select a specific org vDC to be drained as
opposed to draining all prepops.
Clear Errors: When a prepop fails to deploy, VMware Learning Platform marks it as an
error and shows the count of errors. Clearing the errors marks the database record for the
error as cleared and drops the current count of errors to zero.
Fill Up: Sends a fill up equal to the “Fill up” value (number of prepops that should be
deployed).
Set to Refill: Value for the least amount of available prepops. If the number of available
prepops goes below the Refill At value, then the system deploys prepops (refills) until the
Refill At value is met.
Reset Average Deploy Time Statistics: VMware Learning Platform monitors the average
lab deployment time and continuously updates the average as end users continue to start
(deploy) labs. This is the estimated deployment time an end user sees when launching a
lab. The Reset Average Deploy Time Statistics option clears the statistics for the selected
template to restart the calculation for the average deploy time.
You can enable display of the average deploy time statistics on the vApp Template List.
Doing so allows you to easily know which are the slowest vApp templates and thus
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•

which to reset. Note that you can click the Reset all average deployment time statistics
option on the vApp Template List to reset all the vApp templates at once.
More Details: Displays details of the selected vApp template similar to the following
example:

Mass Actions
The vApp Template List includes a mass action pulldown that you can use to perform an action
on all vApp templates. The pulldown includes the Clear Errors option.

When a prepop fails to deploy, VMware Learning Platform marks it as an error and shows the
count of errors. The Clear Errors option clears all errors, for all the vApp templates listed and
drops the current count of errors to zero.
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Working with the Labs List
A lab is a collection of metadata, a single vApp Template and an instructional manual. The Lab
List allows you to create labs and manage existing labs.

Creating a Lab
To create a lab:
1. Click Labs/Catalog Info>Labs. The Lab List opens.
2. Click on Create Lab. The Create Lab form opens with the Basic Lab Info tab current:

3. Enter details about the lab you want to create:
a. Lab Code: A short string used to identify the lab; it must be unique in the system.
This string appears in the vApp name of all of your deployed vApps in VMware
vCloud Director.
b. Name: Give the lab a descriptive name.
c. Deployment Pool: Select (from the Manage List View pull-down) a deployment
pool for the lab. The lab’s virtual machine metadata, which is primarily the
username, password, notes and a flag for each virtual machine, will be based upon
the vApp template(s) included in the deployment pool you select.
4. Click Create. The Edit Settings tab opens.
5. In the Settings tab, configure your lab settings:
a. Enabled: Enables/disables the lab.
b. Public Visible: Enable/disable the public visibility of the lab. Labs have a public
visible property as do tenants. If you configure a tenant to allow public browsing
and make your lab publicly visible, then an end user will be able to browse the
Catalog page on the end user UI without being logged in.
c. New Lab: Inserts a “new” badge on the lab in lab console. Badges are images that
VMware Learning Platform displays in the top right of the lab console user
interface. These images allow the end user to tag a lab. In the lab console user
interface, an end user can click on an icon to display a listing of labs with similar
items. You can create badges using the Catalog Info>Badge option
d. End Allowed: If enabled, once an end user “ends” a lab, then that user is never
able to return to the lab again. If deselected, the End button in the end user UI is
hidden.
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e. Exit Allowed: If enabled and an end user exits a lab, then that user is able to come
back at a later time. If deselected, the Exit button in the end user UI is hidden.
f. Reset Allowed: If enabled, then the lab console will include a Reset option. If a
lab user resets a lab, then all its virtual machines (VMs) will be restored to their
original state. The lab user will not be able to recover any work done.
g. Prepop Enabled: If enabled, VMware Learning Platform deploys one or more
prepopulated (“prepop”) instances of the vApp to the cloud ahead of a user
request. When an end user chooses the lab, the user is then linked to a prepop.
This process reduces the amount of time an end-user needs to wait for a lab to be
built by VMware Learning Platform. However, be aware that Prepop uses cloud
resources that could incur costs to your organization.
Note: The system derives prepop values from the deployment pool you chose for
this lab. You can edit those values by editing the deployment pool.
h. VApp Exit Power Off: If enabled, when an end user exits lab, the system powers
down the vApp. If not enabled, the vApp remains powered on (using cloud
resources) after the user exits. This allows for faster resumes when the user
returns.
i. VApp Exit Attempt Shutdown: If enabled, each virtual machine within the vApp
attempts to shut down gracefully before powering off. You must also enable the
VApp Exit Power Off in order for this option to work.
If you do not enable VApp Exit Attempt Shutdown, then when VMware powers
off a vApp, there is a chance that data may be lost or corrupted.
Note: In order for VApp Exit Attempt Shutdown to work properly, the virtual
machine must be running a supported operating system and have the required
VMware tools.
j. Show Notes Button On Lab Console: If enabled, then the Notes button will be
included on the lab console once an end user starts this lab. If the end user clicks
the Notes button, then the console displays metadata such as notes, username and
password for each VM. You (the tenant admin) can use the Edit VM Metadata tab
to specify such metadata. Note that the Edit Tenant page also includes this option
as a tenant-wide default. You can enable/disable the tenant-wide default using the
“Use Value From Tenant Option” checkbox.
k. Open Notes Panel On Lab Start: If enabled, then the lab console will, by default,
display metadata (notes, username and password for each VM) for this lab once
an end user starts it. Note that the Edit Tenant page also includes this option as a
tenant-wide default. You can enable/disable the tenant-wide default using the
“Use Value From Tenant Option” checkbox.
l. Require Grading: Enables Grading. You can use the Entitlement List to enter
grading information and provide a means for the end user to review that
information. If you do enable the Require Grading option, then:
i. Edit Settings tab displays “Time Period for Grading” field. This field
allows you to specify a time period during which the lab may be graded.
During this time period, the system retains the entitlement (and retains the
vApp). Thus, an end user can take the lab and the entitlement remains
active until either the lab has received a grade, or the grading period has
passed.

TENANT ADMINISTRATOR REFERENCE GUIDE /37

Tenant Administrator Reference Guide

m.

n.

o.

p.

q.

r.

s.

Note: If you set the “Time Period for Grading” to zero (0), then the system
retains the entitlement (and vApp) indefinitely.
ii. Lab console will include the “Finish” option instead of the “End” option.
If the end user clicks Finish, then the system displays a prompt stating that
the lab will be submitted for grading.
iii. Lab console’s Transcript tab (it lists Labs Completed) will state that the
lab has been submitted for grading.
iv. Lab console’s Enrollment’s tab will state that the lab has been submitted
for grading.
Power Off for Grading: If the end user clicks Finish on the lab console and thus
moves the entitlement into the Awaiting Grading status, or if the end user runs out
of time when taking a lab, then the system powers off the vApp if this option is
enabled. If this option is not enabled, then the vApp keeps running. Thus, the
purpose of the Power Off For Grading option is to save resources by powering off
the vApp when it isn’t being used.
Undeploy After: If you enter a value more than zero, then the tenant allows
automatic undeployment of an inactive lab in the cloud. If you make this option
active, then users returning to their lab have to wait for it to be deployed again
before they can use it. If your organization is resource-constrained in the cloud, or
is using a pay-as-you-go model for resource usage, then you can limit your
resource usage by selecting this option. The disadvantage is that a deploying lab
can take a time.
Time Extension Enabled/Use Value from Tenant Option: Toggles between
enabling lab time extension for this lab only or using the tenant-wide value as set
on the Edit Tenant page.
Maximum Extension Times/Use Value from Tenant Option: Toggles between
enabling a maximum extension times value for this lab only or using the tenantwide value as set on the Edit Tenant page.
Time Extended Per Request/User Value from Tenant Option: Toggles between
enabling a time extended per request value for this lab only or using the tenantwide value as set on the Edit Tenant page.
Concurrent Users Limit: Limits the number of concurrent users that can start this
lab. The system performs a check on the limit versus the number of users
currently running the lab and will not allow another lab to be started once the
limit has been reached. For example, if the limit had been set to 10, then the
system would not allow an 11th user to start the lab.
Note: The system’s concurrency check is independent of running vApps for the
lab and does not consider any deployed prepops. Powered-down vApps due to an
exited lab, powered-down labs due to being idle and redeployed vApps due to
reset vApps are all not considered in the system’s concurrency check.
Time Allotted Override: If you are using the VMware Learning Platform API to
enable a user for a lab, you can pass a time allotted. If you do pass a time allotted,
then you will override the time allotted value in the lab configuration page. If the
Allow 3rd Parties box is not checked, then VMware Learning Platform sends an
error back to the API call stating the value for this lab cannot be overridden.
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i. Time Allotted: Amount of time, in hours, the user gets to do the lab. This
is different than the Valid Period setting, next. For example, if the user
gets 30 hours to do the lab within a 30-day period, the Timelimit is the 30
hours setting.
ii. Valid Period: Amount of time the lab stays active. This is different than
the Timelimit setting, above. For example, if the user gets 30 hours to do
the lab within a 30-day period, the Valid Period is the 30-day setting. You
can include hours and minutes in this setting.
t. Entitlement Callbacks: Select an entitlement callback. If no entitlement callback
exists, then click Add Entitlement Callback. See the section “Configuring
Entitlement Callbacks” for information about entitlement callbacks.
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u. Callback MetaData: Metadata the system will include in the callback you selected
in the Callbacks field. For example, if you enter the text “test callback metadata”
and the callback you selected had an email return method, then the callback would
return an email similar to the following example:
{
"entitlementKey":"NEE-97385361_1_07500"
"account": “jsmith@project.com”,
"sku":"shortlab",
"tenant": "NEE",
"eventTime":"01-07-2016 18:11:25 UTC",
"event": "enroll",
"firstName": "John",
"lastName": "Smith",
"metadata": "test callback metadata"
}

6. Click Update. The Edit Content and Metadata tab opens.
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a. Short Description: Provide a short description of the lab. This short description
will appear, if enabled, within the Lab List (Admin UI) and also within the lab
console’s Labs tab.
b. Description: Enter a more complete description of the lab. This more complete
description will appear within the lab console’s Labs tab if the end user clicks the
Read more option.
c. Network Topology: Select an image showing the network topology of the virtual
machines that comprise the lab. If you do not choose a topology image, then
VMware Learning Platform will hide the Network Topology button in the lab
console for this lab.
Note: You need to have already created a network topology image using the
Catalog Info>Network Topologies option.
d. Manual: Select a manual for the lab from the list of available manuals. If you do
not choose a manual, then the Manual window in the lab is blank. Selecting a
manual makes available all the language versions of it that have been published.
Note: Importing an instructional manual is done using the Content Engine
(Content>Content Engine option).
e. Thumbnail: Select a thumbnail image to display for your lab. If you do not select
an image, then VMware Learning Platform will use the default lab thumbnail
image.
Note: You need to have already created a thumbnail using the Catalog
Info>Thumbnails option.
f. Survey: Select an existing survey from the pull-down. The system assigns the
survey you select to the lab. When an end user ends the lab, the system will
prompt the user to the survey you selected.
g. Screenshot: Uploads the image you select. It will appear in the lab console user
interface when the end user clicks on Lab Details. You can browse to any
screenshot that meets the display limits. The following figure shows an example
of the Lab Details in a lab that includes a screenshot.

Note: On the Screenshot field of the Edit Content and Metadata tab, you can click
the X to delete an existing screenshot.
h. Badges: Badges are images that VMware Learning Platform displays in the lab
console. An end user taking a lab can click on a badge to display a list of labs
associated to that badge.
Note: You need to have already created a badge using the Catalog Info>Badges
option.
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i. Products: Labs are often categorized by product. For example, a lab could be
about the VMware product Horizon. Select a product to associate it to the lab.
Note: You need to have already created a product using the Catalog
Info>Products option.
j. Tags: Tag a lab with a text string. The text string will appear on the lab console.
An end user can click on the tag to display other labs with the same tag.
Note: You need to have already created a tag using the Catalog Info>Tags option.
k. Authors: Select an author for the lab. An end user can click on an author to
display the author’s public profile.
l. Related Labs: Allows you to relate to the lab you are creating to the lab you
select. VMware Learning Platform will display these related labs when an end
user clicks on the Lab Details option in the lab console user interface. For
example, if you were creating an introductory lab about VMware vCloud
Director, you could select related labs such as “Advanced VMware vCloud
Director” or “Using Log Insight with VMware vCloud Director”.
7. Click Update. The Edit VM MetaData tab opens.

a. Use Initial Console from Deployment Pool: If enabled, the lab defaults to the
initial console as defined in the vApp of the deployment pool you selected in the
Basic Info tab.
b. Initial Console: If enabled, the lab will use this virtual machine as its initial
console instead of the one from the deployment pool.
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c.

> :Click to edit the metadata of an initial console.

Note: You can enable the “Use value from Deployment Pool” fields to utilize the
configuration contained in the deployment pool to which the lab is associated.
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•

Visible: If enabled, then the virtual machine is visible in the lab. (If not
enabled, then VMware Learning Platform will not have console
connection.) For example, consider a lab with 12 virtual machines. You
can use the Visible option to have the lab end user have access to only a
single virtual machine.
Note: If you select only one virtual machine to be visible to the end user,
then VMware Learning Platform will hide the console chooser that is
normally on the left-hand side of the console screen of the lab console.
• Power On VM When Lab Starts: Specifies that the VM in the vApp
should be powered on when the entitlement starts. If enabled, then the
system can more efficiently determine the power state of the VM and thus
reduce the time it takes to start the lab. Note the following:
o If all the VMs in a deployment pool or lab are marked as being
powered on, then the system will start the vApp instead of the
individual VMs which delegates the powering-on operation to the
cloud. This delegation means the VMs in the vApp will be
powered on as configured for the template in the cloud. Thus, the
system will observe any configured power up order, pauses or
other tasks as configured in the cloud.
o If the VM marked as the initial console is not marked to be
powered on at start (and other VMs are marked for power on), then
the system will display a warning in the Lab List.
• Allow Console Resize: If enabled, then a lab user can manually resize the
lab console.
• Automatic Console Resize: If enabled, then the system will automatically
scale a lab console so that it fits the available space.
Note: If both Allow Console Resize and Automatic Console Resize are
enabled, then the system will initially size the lab console, but the lab user
will still be able to resize it manually.
• Username: You can specify a username specific to the virtual machine.
• Password: You can specify a password specific to the virtual machine.
• Notes: Notes an end user might need when interacting with a virtual
machine. For example, you could include license keys in a note. Notes
supports rich text/HTML information on the virtual machine for the lab.
VMware Learning Platform displays the notes when an end user clicks the
Notes option on the lab console toolbar.
• Use Individual VM Power On Settings: If enabled, then VMware Learning
Platform controls the powering on of VMs according to the setting of the
Power On VM When Lab Starts option (described above). If not enabled,
then the cloud controls the powering of VMs. Cloud powering settings are
determined outside VMware Learning Platform.
Note: This option only regards the delegation of VM power on operations
either to the cloud or to VMware Learning Platform. Prepop deployment
always delegates power on operations to the cloud.
8. Click Update. You have created a lab. The Lab List should now include the lab that you
just created.
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Deleting a Lab

The Lab List allows you to access a pull-down that includes the Delete Lab option. If you cannot
successfully delete a lab, the likely cause is active prepops or entitlements. If you cannot delete a
lab, try the following solution:
1. Ensure the lab is enabled and prepops are enabled.
2. Go to the Prepops page and set prepops to 0 (zero).
3. Enable and acknowledge all alerts.

Exporting Notifications
The Lab List includes an Export option. The Export option allows you to export all notifications
to a CSV, Excel or PDF.
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Working with the Catalogs List
A catalog “contains" labs. The Catalog List allows you to create and manage catalogs.

Creating a Catalog
Once you have created a lab, you must create a catalog to contain it:
1. Click Labs/Catalog Info>Catalogs. The Catalogs List opens.
2. On the Catalogs List, click Create. The Create Catalog form opens with the Basic Lab
Info tab current.

3. On the Create Catalog form, configure the lab catalog with the following settings:
a. Name: Give the lab catalog a meaningful name. This name will appear in the
Catalog List.
b. Short Description: Provide a short description of the catalog. This description will
appear, if enabled, in the Catalog List. It will also appear in the lab console within
the Labs tab to describe each catalog.
c. Description: Provide a more complete description of the catalog. This description
will appear, if enabled, in the Catalog List (Admin UI).
d. Enabled: Select to enable the lab catalog. If not selected, the default, the lab
catalog is saved in the system but not available to any VMware Learning Platform
tenants.
e. Public Visible: Enables/disables the public visibility of the catalog. If public
visibility is disabled in the catalog, then any labs in the catalog that have their
public visibility enabled will not be publicly visible.
f. Labs: Select an available lab. The lab(s) you select become associated with this
catalog. A lab must be associated with a catalog in order for it to be listed within
that catalog in the End User interface.)
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g. Tenant Groups for this Catalog: Select which groups of users in your tenant can
see this lab. Do not leave this field blank. You must select a tenant group or the
catalog you are creating will not be visible.
4. Click Create. The system creates the catalog and opens the Lab Ordering tab.

5. You can optionally change the order of the labs included within the catalog. Click on the
first column’s header - to sort by that column, then drag and drop a row(s). The lab
order within the Lab Ordering tab determines the order in which the system will display
the labs in the lab console. In the example above, the Lab Ordering tab for the catalog
“Test”, lists the labs CS101, CS200, CS300 and CS400 and thus the system will display
them in exactly that order within the lab console.

6. Once you are content with the lab ordering, click the X to close the Catalog form.
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Changing Catalog Order
You can change the order of the catalogs as they appear in the Catalog List and in the lab
console.
1. Click Labs/Catalog Info>Catalogs. The Catalogs List opens.
2. In the Catalog List, click on the first column’s header - to sort by that column, then
drag and drop a row(s). In the following example, the catalog “Time Test” has been
dragged/dropped to the top of the list.

The lab console will reflect the ordering in the Catalog List as shown in the following
example:
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Working with the Badges List
Badges are images that VMware Learning Platform displays in the lab console. The following is
an example of a badge - “NEW”:

If an end user clicks on NEW, the system displays a list of labs associated to that badge:
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Creating Badges
You can add pre-configured badges to your tenant or create your own badge. The following
procedure describes how to add a pre-configured badge:
1. Click Labs/Catalog Info>Badge to open a list of badges already included in your tenant.
The Badge List opens:

2. On the Badge List, click Add Default Badges. The following message appears: "Add
default Advanced, Beginner, Full Length, Lightning, Product and Use Case badges?"
3. On the message box, click OK. The Badge List opens.
4. On the Badge List, select Beginner. The Edit Badge form opens. The system fills-in the
fields of the Edit Badge form for you as shown in the following example:

5. Click Update. The system adds the Beginner badge to your tenant.
Note: You associate a badge to a particular lab using the Badges field within the Edit
Content and Metadata tab of the Lab Form (Labs>Labs).

TENANT ADMINISTRATOR REFERENCE GUIDE /50

Tenant Administrator Reference Guide

Working with the Network Topologies List
A lab is comprised of virtual machines. You can include an image to your tenant that shows the
network topology of the virtual machines that comprise a particular lab. An end user taking a lab
can then click on the Network Topology option to display the lab’s network topology.

Creating Network Topologies
1. Click Labs/Catalog Info>Network Topologies to open list of existing network topology
images.
2. Click Create Network Topology to open the Create Network Topology form which
allows you upload more network topology images.

o Name: Name of the network topology image as it will appear in the Thumbnails
List.
o Image/Browse: Topology image to which you browse.
o Click Upload to upload the topology image you selected.
o Click Create to create the network topology image you selected and thus include
it within your tenant.
Note: You associate a network topology to a particular lab using the Network
Topology field within the Edit Content and Metadata tab of the Lab Form
(Labs>Labs).
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Working with the Product List
At an event (for example, VMworld) labs are often categorized by product. For example, an
event might include multiple labs about the VMware product Horizon. Thus, you can create a
product name, in this example Horizon, to which you can map the Horizon-related labs. Proctors
can then direct users to the Horizon-related labs.
The following is an example showing the products vCA and vCloud Director.

If an end user clicks vCloud Director, the system displays a list of all labs associated to that
product:
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Categorizing a Lab as a Product
To add a product to your tenant:
1. Click Labs/Catalog Info>Products to open the Product List.
2. Click Create Product to open the Create Product form.

3. Enter a name for your product and click Create. The Show Product page opens.

4. You can edit or delete the product you just created by using Edit or Delete from the
pulldown on the Product List.
Note: At this point the product you created is associated to your tenant but not to any
labs. Use the Products field of the Edit Content and Metadata tab of the Lab form (Labs
Catalog Info>Labs) to associate a product(s) to a lab.
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Working with the Tag List
A tag is a text string that you can add to your tenant. An end user taking a lab can click on a tag
to display of list of all labs associated to that tag. The following is an example showing the tag
“testtag”.

If an end user clicks testtag, the system displays a list of all labs associated to that tag:
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Tagging a Lab
To add a tag to your tenant:
1. Click Labs/Catalog Info>Tags to open the Tag List.
2. Click Create Tag to open the Create Tag form.

3. Enter a text string in the Name field (for example, testtag).
4. Click Create. The View Tag form opens. The following is an example:

Note: You associate a tag to a particular lab using the Tags field within the Edit Content
and Metadata tab of the Lab Form (Labs>Labs).

TENANT ADMINISTRATOR REFERENCE GUIDE /55

Tenant Administrator Reference Guide

Working with the Thumbnails List
A thumbnail image is associated to a particular lab. VMware Learning Platform displays
thumbnail/lab association in the end user lab console. The following is an example:

Creating Thumbnails
To add a thumbnail to your tenant:
1. Click Labs/Catalog Info>Thumbnails to open a list of existing thumbnail images.
2. Click Create Thumbnail to open the Create Thumbnails form which allows you upload
thumbnail images.

o Name: Name of the thumbnail as it will appear in the Thumbnails List.
o Image/Browse: Thumbnail image to which you browse.
Note: The thumbnail you select must conform to the following specifications:
100x100 pixels; 24 bit; PNG file.
o Click Upload to upload the image file you selected.
o Click Create to create the thumbnail image you selected and thus include it
within your tenant. You can associate the thumbnail image to a particular lab
using the Lab Management Form.
Note: You associate a thumbnail to a particular lab using the Thumbnail field
within the Edit Content and Metadata tab of the Lab Form (Labs>Labs).
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Working with the Account List
Use the Account List create, list, edit and act upon existing user accounts.

Creating User Accounts
To create a user account:
1. Click Security>User Controls. The Account List opens.
2. On the Account List, click Create. The Create Account form opens to the Basic Account
Info tab:

3. In each section of the Create Account form, enter the information for the user you want to
create.
a. Username/Email: Enter an email address for the user you want to create.
b. First Name: User’s first name.
c. Last Name: User’s last name.
d. Display Name: VMware Learning Platform displays the display name you enter
on the user’s lab console screen beneath the text “Welcome,” (for example
“Welcome, John Smith”).
e. Company: User’s company or organization name.
f. Password: Password user to use for authentication.
g. Confirm Password: Confirm user’s password you entered.
h. Generate Random Password: Enable to have system generate a user password.
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i. Show/Hide Password: Enables/disables showing of password you enter.
j. Send Welcome/Verify: Enable/disable sending an email to the user you are
creating.
Notes:
A. Users can have access to more than one tenant. If the user you are creating
already has access to another tenant, then that user will not get a “Welcome to
VMware Learning Platform” email. A user gets the “Welcome to” email only
upon the first tenant to which access is granted.
B. The “Welcome to VMware Learning Platform” email includes a verification
link. The user must use the link to verify the account. If the user does not verify,
then VMware Learning Platform provides a one-week “grace period”. During the
grace period, the user will have access to VMware Learning Platform but with
some features being restricted. Restricted features include social media, the
sending of transcripts and sending an invite to friends. If the grace period expires
and the user still has not verified the account, then VMware Learning Platform
blocks all access.
4. Click Create. The User Access tab opens. Use it to assign a user to any combination of
rolls:

a. User Role: Entitles user to log into the end user UI and take a lab. The User Role
does not include permission to any other UI (for example, no permission to the
Admin UI or Content Engine).
b. Admin Role: You (the tenant administrator) can assign the role of “Admin” to the
user you are creating and thus create another tenant administrator. The Admin
Role is the most powerful user within a tenant as it includes permission to all the
user interfaces (for example, the Admin UI, end user UI, Content Engine UI and
so on).
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c. Proctor Role: User you consider to be familiar with the content in the various
labs of the tenant. When end users have a question with a lab, they can use an
option on their lab console screen. The option runs an app running on the
proctor’s mobile device to notify the proctor that someone needs help. A user
having an Event/Proctor Role can log into the Admin UI, however the system
defaults to the Proctor dashboard.
d. Support Role: Assigns a subset of the admin permissions. A user having a Support
Role can log into the Admin UI, however the system defaults to the Entitlement
List and allows only the Reset/Remove vApp action as shown in the following
example:

e. Instructor Role: Users assigned this role will appear in a list accessible from the
Create Class form. A Tenant Instructor can monitor the progress of selected
students (a “class”), taking a specified lab at a specified time (“instructor-led
lab”).
A user having a Tenant Instructor Role can log into the Admin UI, however the
system defaults to Class List and allows the user to modify a class. The system
also allows a read-only permission to the Entitlement List.
Note: The Edit Tenant page includes the option “Allow Instructors Access To All
Classes”. If enabled, then an instructor can go to the Class List and view all the
classes in the tenant. If disabled, then the Class List lists only those classes to
which the instructor has been assigned.
f. Certification Grader Role: Users assigned this role can view a list of entitlements
(Entitlement List) that need to be graded and can assign them a score and a grade
string. A user with a Certification Grader role user can edit these anytime until
clicking on Graded.
g. Content Creator Role: Users assigned this role have permissions only to the
Content Engine. The Content Engine allows a user to create/edit/manage
instructional content (lab manuals).
h. Tenant Groups: Select a group or groups to which to associate the user account.
5. Click Create. VMware Learning Platform creates your new user and opens a page that
shows information about that new user.
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Editing User Accounts
To edit an existing user account:
1. Click Security>User Controls. The Account List opens. It lists all user accounts for the
tenant.
2. Click on an existing user name (user names are typically an email address and are
highlighted in blue) to open the Edit Account tab. The following is an example:

3. On the Edit Account tab make your edits to the user account fields and then click
Update. Likewise, you can open the User Access tab to make changes to the user’s role.

Using the Account List’s Action Options
The Account List includes an Action pull-down.
1. Click Security>User Controls. The Account List opens.
2. On the Account List, click the checkbox next to a user account, then click
open a pull-down of action options.

to
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•
•

Remove from tenant: Removes all accounts in the Account List from the tenant.
Move to tenant: Moves all accounts in the Account List from the current tenant to the
selected tenant (selected from a pull-down) as shown in the following example:

•

Copy to tenant: Copies all accounts in the Account List from the current tenant to the
selected tenant (selected from a pull-down) as shown in the following example:

•

Download: Allows you (the tenant admin) to download comma-separated values (CSV)
of the users selected in the list.
Send new token: Sends a verification email to the user when a tenant user account is set
up. The purpose of the email is to validate that the user’s email address is authentic.
Unlock Account: Unlocks all accounts in the Account List.
Note: The system will lock an account when an end-user, while trying to log into a lab,
answers the security questions wrong three times. At the time of locking (third wrong
answer), the system sends an email to the email address of the account. The email
contains a verification link that unlocks the account.

•
•

Using Additional Account List Options
The Account List includes several other useful options: Flush Questions, Login as User and Print
One Time Password

Flush Questions
Flush Questions removes a user’s security questions. The option is useful in cases where
someone having a user role has set security questions but cannot remember the answers.
Flushing the user’s security questions allows the user to login with a onetime password (OTP)
and then set new security questions.
Note: Flush Questions must be enabled per-tenant (by a super user). If you note that the Flush
Questions option is inactive for a user, the likely reason is, the user has a role greater than a “user
role” in another tenant.
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Login as User
If an end user reports a lab console problem/issue, you can use the Login as User option to log
into the lab console as the selected user. The Login as User option allows you to see exactly what
problem/issue the end user has reported. To use this option, proceed as follows:
1. Select a user (for example, jsmith@rainpole.local) then click Login as User.

2. On the notification that appears, click/drag the Login URL into your browser’s address
field.

The system logs you out of your current session and logs you into the lab console as the
user, in this case “jsmith” as shown in the following example:
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Print One Time Password
Print One Time Password allows you to print the selected user’s one-time password.

Uploading/Removing/Downloading Bulk Users
The Account List includes options to upload, remove and download many (bulk) users at once by
means of a CSV file.
Note: The Bulk User option supports CSV files that specify user roles (user, admin, proctor,
support, instructor, grader, content creator).
The following procedure is an example of uploading bulk users:
1. Click User Bulk Upload to expand the option. It includes three tabs and defaults to
Upload CSV:
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2. Click Browse to select a CSV file as shown in the following example:

Note: You can optionally click
to open the File upload format information page.
Along the bottom is the Download Sample of CSV file format option. It downloads a
sample CSV file that is useful to gain an understanding of the file format the system
expects.
3. On the Upload CSV tab, you can select any of the following options:
a. Send verification email: System will send you (tenant admin) an email to verify
your csv file download.
b. Download Results: System will send you (tenant admin) an email at the end of
the mass upload operation with a success/failure status. If the operation is a
success, the email will include a list of the imported accounts.
c. Export fields: Selects the columns to be included in your csv file.
4. When you are done with the Upload CSV tab, click Next. The Preview tab opens.

5. Once you have verified your bulk upload, click Finish. The system creates the users
included in your CSV file and adds them to your tenant. Remember to refresh your
Account List.
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Listing Tenant Admins and Proctors
Use the Account List (User Role Controls) to list tenant administrators and proctors.
1. Click Security>User Role Controls. The Account List opens.

2. Click Show All Admins to list all admins or click Show all Proctors to list all proctors.
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Working with the Tenant Group List
Tenant groups allow you (the tenant administrator) to enact group permissions as follows:
• All user accounts in the group you created have permissions to the catalogs associated to
the group.
• When you create a catalog (Create Catalog page) you can select which tenant groups
have permission to the catalog.

Creating a Tenant Group
To create a tenant group:
1. Click Security>Tenant Groups. The TenantGroup List opens.
2. On the TenantGroup List, click Create. The Create TenantGroup page opens.

3. In the Create TenantGroup page:
a. In the Name field, enter a name for the tenant group you are creating.
b. In the Catalogs field, select a catalog or catalogs that you want associated to your
tenant group.
c. In the Accounts field, select the user accounts you want associated to your tenant
group.
4. Click Create. The Show TenantGroup page appears which summarizes the tenant group
you just created as shown in the following example:
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Editing Tenants
To edit an existing tenant:
1. Click Tenant Management>Tenant Info. The View Tenant page opens which shows
the administrative settings of the tenant.
2. Click Edit. The Edit Tenant page opens.

3. You can click on any heading on the Edit Tenant page in order to edit the fields contained
within that heading.
4. Once you are done editing your tenant, click Update.

About the Edit Tenant Options
•

Required Field:
o Display Name For Tenant: Name of the tenant that VMware Learning Platform
will display in the user interfaces.
o Name: This field is not editable. It only displays the name of the tenant in
VMware Learning Platform database.
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•

•

•

•

Custom Messages:
This section contains fields that allow you to enter your own lab messages in place of the
default messages. For example, for the field Lab Submitted for Grading, the default is
“Thank you for taking this lab. An instructor will grade your lab”. You could change the
default to “Your lab will be soon be graded.” Thus, the Custom Messages section allows
you to customize the messages sent by the labs of the current tenant.

Note: For the Error Message For Maximum Allowed Entitlement Reached field, the
system will replace the strings{maxAllowed}and{current} with the number of active and
current entitlements. Example: the system could return the message “Only 4 concurrent
enrollments are allowed for this lab and 4 enrollments already exist.” You can set the
values for [maxAllowed} and {current} within the User Hard Cap section.
Details:
o Administrative Contact: Email address of the person in your organization
assigned to act as your tenant’s administrative contact. You can select an email
address from a pull-down of tenant user email addresses.
o Cost Center: Typically to identify a cost center for VMware Learning Platform
customers internal to VMware.
o Technical Contact: Email address of the person in your organization assigned to
act as your tenant’s technical contact. You can select an email address from a
pull-down of tenant user email addresses.
Email: VMware Learning Platform sends emails to users such as “welcome” emails or
“password change” emails. The Email page includes the Click Here to Customize Your
Email link. It opens an editor that allows you to customize the format of emails sent by
VMware Learning Platform. If you do not customize, then VMware Learning Platform
will use its default system email formats. The Email page also includes the “Return
Address” field. Use this field to update the return address for all e-mails sent on behalf of
your tenant.
Entitlement Times: Entitlements refer to lab time limits and lab valid periods. A Time
limit is the amount of time, in hours, users get to work on a lab. Valid period is the
amount of time a lab stays active.
o Enforce Extension Limit For Proctor: If enabled, then the specified Maximum
Extension Times also applies to proctors.
o Maximum Extension Times: Sets a maximum number of times lab users can
extend the time remaining for a lab. For example, a value of 5 means lab users
cannot extend a lab’s “time remaining” more than five times.
o Time Extended per Request: Sets a value, in minutes, by which a lab’s time
remaining is extended each time a user clicks on the Extend option. For example,
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•

a value of 2 means the lab’s “time remaining” is extend by 2 minutes each time a
user clicks the Extend option.
o Time Extension Enabled: If enabled, then the lab console displays the Extend
option.
o Time Remaining to Show Danger Prompt: Sets a time value (for example, 1
minute) for the lab console to display a lab “time remaining” danger prompt.
o Time Remaining to Show Warning Prompt: Sets a time value (for example, 3
minutes) for the lab console to display a lab “time remaining” warning prompt.
Event Mode: Includes options to manage credits, event statistics and other event
parameters. A credit allows a user to take a lab. At an event, badge scanning technology
creates credits. As well, a tenant admin can add or remove a credit using the Admin UI
(Security > User Controls). The User Controls page includes an Event Credits column.
A tenant admin can use the column to assign a value of None, Browse or Enroll.
o Event Credit Check Enabled: Enable/disable credit check.
o Event Dashboard Content Cycle time: At events, VMware Learning Platform
staff provides a dashboard that lists statistics. The dashboard is somewhat like a
slide show on a continuous loop. Cycle time refers to much time each slide stays
up on the dashboard before going to the next slide.
o Enable Mode Enabled: If enabled, then:
▪ System assigns a seat to each (non-tenant admin) user logged into the
tenant. The seat can be either traditional (workstation) or BYOD (bring
your own device). Traditional seats should have a workstation registered
with the current browser. Otherwise, when a user logs into the tenant, the
system displays a prompt to choose from available BYOD sections.
Notes:
• The Event Manager provides options to configure BYOD sections.
• Edit Tenant page includes an option (Treat Proctors as Normal
Users) that forces proctors and tenant admins to have assigned
seats.
▪ System pushes updates to the dashboard’s statistics panel (Dashboard)
and the Proctor Interface (Events>Proctor Interface).
▪ System enables the Raise Hand button (help requests) on the lab console.
▪ System enables the Event Credit Check Enabled tenant option. Two types
of credits exist, Browse and Enroll. If the tenant uses credits during event
mode, then in order to log in a user must have either a valid Browse or
Enroll credit or a valid entitlement in the tenant. A Browse credit allows
the user only to browse but not enroll into a lab. A user can utilize an
Enroll credit to enroll into a lab. Once the user enrolls, the system removes
the credit. Events utilize scanning technology. To get a credit, a user’s
badge must be scanned upon arriving at the HOL area. The credit ensures
that the user will be able to take only one entitlement and not stay on the
station for a prolonged period of time.
o Event Client Content Cycle Time: Similar to dashboard cycle time but refers to a
slideshow that acts as a screensaver on station desktops.
o Lanyon API/HOL/API URL: These options are for badge scanning at events
where registration is provided by the Lanyon events registration company. If you
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want to use the badge-scanning feature, contact the VMware Learning Platform
staff.
o Time to Live for Credits: Credits issued to a user are only valid for a certain
period of time before they expire.
o Max Station Token Time: At events, VMware Learning Platform staff provides
several desktops attendees can sit down and use. These desktops are known as
stations. When VMware Learning Platform staff registers a station, it gets a
unique seat number associated with it and a cookie in order to identify which
station it is. The token time specifies the length of time the cookie is valid before
it times out thus preventing someone from potentially stealing the cookie and
using it on their own machine.
o Number of Credits Granted to a User from Single Scan: Specifies the number of
credits VMware Learning Platform grants when an end user’s badge is scanned.
At an event, customers who want to take a lab have their badges scanned. The
scanner app sends a request to VMware Learning Platform to add the specified
number of credits to the user’s account.
o One-time Password Length: Number of characters for a one-time password.
When a tenant administrator first creates a user in VMware Learning Platform,
the account must be verified. Normally this is done by sending an email to the
user with a verification link. At events, this practice can become problematic
because many users do not have access to their email. To address this problem,
VMware Learning Platform creates a random one-time password for the user (for
example, 98fds788). VMware Learning Platform staff then prints the one-time
password on the badges for the event so users have a known, good password,
which one can use to log in the first time. After the first login, VMware Learning
Platform prompts the user to set security questions and change his/her password.
o Treat Proctors as Normal Users: Enable/disable allowing an event proctor to be
treated by the system as a normal user.
o Rainfocus API Profile ID/Widget ID/URL: Fields allow you to integrate VMware
Learning Platform with the Rainfocus app. Rainfocus is an event performance
management platform designed to help improve the entire event experience for
exhibitors, vendors and attendees.
o Enable Roost Notification: Enables/disables the Roost notification app. Roost is
utilized by the Event Proctor app. The Event Proctor app is a VMware Learning
Platform application that runs on mobile devices. The app provides a convenient
way for a proctor to move about the event floor and efficiently respond to help
requests from students taking labs.
Event Statistics: At events, VMware Learning Platform staff provides a big video screen
in the middle of the room and on the proctor dashboard.
o Show All Historical Labs (Stats Display): Enables/disables historical labs display.
o Event Statistics Display Start Date: Day/Month/Year/Time.
o Max Active Lab (Stats Display): Maximum number of active labs to display.
o Max Completed Lab (Stats Display): Maximum number of completed labs to
display.
o Max Popular Labs Shown (Stats Display): Maximum number of popular labs to
display.
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o Max Active VM (Stats Display): Maximum number of active virtual machines to
display.
o Max Completed VM (Stats Display): Maximum number of completed virtual
machines to display.
o Started Labs Only (Stats Display): Enable/disable started labs.
General Options:
o Allow Assignment While Deploying: Enables/disables the assignment of cloud
resources before those resources are fully enabled. When enabled, the system
assigns a still deploying pre-pop rather than waiting for an on-demand prepop.
The result is a faster start time for labs in cases where fully provisioned cloud
resources are not available.
o Allow Self Registration: Enables/disables user self-registration. Self-registration
allows users to enter their email address and create their own accounts in VMware
Learning Platform to start using labs. If self-registration is not enabled, then a
tenant admin manually creates the user using the VMware Learning Platform
Admin Dashboard.
o Announcements: Enables/disables display of lab console announcements.
o Auto Run Compatibility Checker When User Starts the Lab: If enabled, then
when a user starts a lab, the system will prompt the user to run a compatibility
check. The user then has the option to either continue to the lab without running
the check, or to run the compatibility check. The compatibility check will show
and save a report.
o Name of Default Prepop Assignment Algorithm: Selects the algorithm the system
will use to assign prepops once an end user starts a lab. This assignment algorithm
selection is the first step (of a two-step process) during which the system assigns
available prepops from a specific vDC. The second step is the Name of Default
Prepop Assignment Preference. You can override this selected tenant-wide
algorithm for a particular vApp template using the Edit Template option. See the
section “

o Edit vApp Template: ”. The prepop assignment algorithms are as follows:
▪ VMware Learning Platform Assignment Algorithm: This is the default
algorithm. It selects a prepop from any available vDC based solely upon
the preference option.
▪ Most Available Prepops: Sets a preference for the vDC having the most
available prepops.
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Most Available Prepops for the Template: Sets a preference for the vCD
having the most prepops deployed from the template being used in the
assignment.
▪ Most Deployments: Sets a preference for the vDC having the most
deployments. This deployment preference includes both prepop and
assigned vApps.
▪ Most Deployments of the Given Template: Sets a preference for the vDC
having the most deployments. This deployment preference includes both
prepops and assigned vApps - of the vApp templates being used.
o Name of Default Prepop Assignment Preference: Selects a prepop preference if
there are multiple prepops available in the assigned vDC. This prepop preference
is the second step of a two-step process. The first step is the prepop assignment
algorithm selection. You can override this selected tenant-wide preference for a
particular vApp template using the Edit Template option. See the section “

o Edit vApp Template: ”. The following preferences are supported:
▪ Prefer Older: Sets a preference for the older prepops (the older the prepop,
the stronger the preference).
▪ Prefer Newer: Sets a preference for the newer prepops (the newer the
prepop, the stronger the preference).
▪ No Preference: Sets a preference randomly.
o Name of Default Prepop Placement Algorithm: Selects the algorithm the system
will use to place new prepop deployments in cases where a template is available
in multiple vDCs. The system will not apply the selected algorithm to on-demand
deployments. The algorithm you select will be applied on a tenant-wide basis.
You can override the selected tenant-wide algorithm for a particular vApp
template using the Edit Template option. See the section “

o Edit vApp Template: ”.
Notes:
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A: When one or more prepops deploy, either as back-fill for deployments that
have been assigned to a user or due to you (the admin) having increased the
number of available prepops, the system will determine into which vDCs it can
deploy the new vApps. If the system determines there are multiple vDCs into
which it can deploy the vApp, then the system will use the selected placement
algorithm. If multiple deployments are being made, the system may spread them
across available vDCs. For a single deployment, the system will select the vDC
that best meets the algorithm’s goal.
B: Changing the default placement algorithm is not recommended. The VMware
Learning Platform Default Algorithm is designed to offer a balanced use of
available resources. Changing from the default algorithm to another could easily
lead to some vDCs being overloaded while others are unused and thus impact user
experience.
The Placement algorithms are as follows:
Note: All algorithms will ignore vDCs that have exceeded their configured hardlimits for availability and will avoid vDCs that have exceeded their soft-limits.
The system may still select these vDCs with a reduced frequency.
▪ VMware Learning Platform Default Placement Algorithm: This is the
default. It attempts to balance distributions across all available vDCs. This
algorithm presumes that if a vDC is available and can be used, then the
system will use it. This algorithm does not use a “balancing step” to
ensure equal load upon all vDCs in the near term. Instead, this algorithm
leaves balancing as a side-effect of the way the system assigns prepops
which will lead to a balanced use of available resources.
▪ Equal By Deployed Template Count Algorithm: Attempts to have an equal
number of vApps for the given template deployed in each vDC in which
the template is available. This algorithm does not consider differences in
resource availability in the vDCs (other than hard and soft limits) and aims
only for equal numbers of deployments. This algorithm considers only the
number of deployments that use the templates being used in the
placement.
▪ Equal By Deployment Count Algorithm: Attempts to have an equal
number of vApps deployed in each vDC based solely on the count of
deployments regardless of the actual resource usage of different types of
vApp. This algorithm does not consider differences in resource availability
in the vDCs (other than hard and soft limits) and aims only for equal
numbers of deployments. This algorithm considers the total number of
deployments in the vDC.
▪ Equal by Resource Utilization Algorithm: Attempts to distribute
deployments across vDCs so that the relative resource utilization of vDCs
is equal. While the system will assign more deployments to vDCs with
more available resources than clouds with fewer resources available, the
proportional resource utilization will be similar.
o Seconds to wait before deleting an expired vApp: Sets the amount of time, in
seconds, the tenant keeps expired entitlements and vApps.
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Facebook Enabled: Enables/disables Facebook feature on lab console.
LinkedIn Enabled: Enables/disables LinkedIn feature on lab console.
Offers: Enables/disables display of lab console offers.
Query Size for Prepop Assignment: VMware Learning Platform assigns the oldest
available prepop first. Once the system has found all the prepops it might assign
when a user starts a lab, it can then order them by their creation date and will
assign the oldest one first. The Query Size option adds some randomness to this
process by finding the available prepops, ordering them by their creation date and
then assigning one by selecting one at random from the oldest range of prepops.
This “oldest range” is the query size for prepop assignment value you specify.
o Lab Rating Enabled: Enables/disables lab rating feature on lab console.
o Days after which a user can re-rate a lab: Sets the rating period per tenant. During
this period, an end user cannot re-rate a lab. For example, if set to 10 days and an
end user rates a lab, then the end user cannot rate the same lab again during the
next 10 days.
o Length of Shortened Strings: A numerical value (minimum is 10 and maximum is
100) that specifies the length of the short strings that the system will use. A short
string is a randomly generated string the system uses in place of longer strings.
The system uses a shortened string value for verification tokens and URLs when
the long string is difficult to type or copy. A short string is much easier for the
system to handle but must be unique within the application. The Length of
Shortened Strings option specifies the length of the generated short string and has
a default value of 12. For tenants with a very large user-base, you may have to
increase the length of this string to ensure uniqueness of the generated strings.
The system does not strictly enforce the minimum and maximum values but
values outside the valid range are moved to the closest limit when the value is
used.
o Minutes Before Shortened Strings Become Invalid: Specifies the amount of time,
in minutes, that short strings remain valid. After this time, the system expires
shortened strings, thus the long strings they represent can no longer be used. The
default value represents one day. You can increase the default to give users more
time to validate their accounts.
o Speed Test Cloud URL: System supports a tenant-specific, speed-test from the
browser to the VMware Leaning Platform. Use this field to change the cloud
endpoint used for the speed-test.
o Twitter Enabled: Enables/disables Twitter feature on lab console.
Instructor Options:
o Allow Instructors to Reset Lab from Class: Enables the Reset option in the
Instructor-Led Lab console. The Reset option resets the vApp.
o Allow Instructors Access to All Classes: If enabled, then an instructor can go to
the Class List (click Classes>Classes) and view all the classes in the tenant. If
disabled, then the Class List lists only those classes to which the instructor had
been assigned.
o Allow Instructors to Send New Token from Class: Enables the Send New Token
option in the Instructor-Led Lab console. The Send New Token option sends
students of a class an email that includes a link to login to the lab console.
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o Allow Instructors to See and Bulk Upload to Users to Tenant: Enables instructors
to access the Account List (Security>User Controls). The Account List includes
the Mass User Controls option (described in the section “Adding/Removing Mass
Users”). Instructors can use the Mass User Controls option to add users to the
tenant by means of a .csv file.
Note: Instructors can use Mass User Controls to specify only username, first
name, last name and company. The system will ignore all other columns in the
.csv file. When an instructor does a mass uploads users action, the system will
create those users with the Tenant User role and add them to the All Users group.
o Allow Instructors to Manage Lab and Entitlements of a Class: Allows instructors
to add/remove entitlements to/from a class or add/remove labs to/from a class.
Interface:
o Allow Anonymous Catalog/Lab Browsing: If enabled, allows anonymous
browsing. Anonymous browsing means that users can browse the catalog even if
they are not logged into VMware Learning Platform. Thus, end-users can view
what labs are available before actually before registering with a site (otherwise,
only registered users can view what labs are available.
o Allow Raw CSS Styles in Manual Content: Enable/disable allowing raw CSS
styles in a lab manual.
o Allow Console Resizing: If enabled, then a lab user can manually resize the lab
console.
o Anonymous Language: Select a language for anonymous users from the pulldown. When an anonymous user opens the lab console, the default language will
be in the language you selected.
o Default Console Location: Select form Right, Left or Center.
o Number of days of data in mean deployment time calculation: Specifies a value
(in days) which the system uses to calculate the average deploy time. This value
defines the average shown to an end user when starting a lab. The system
calculates average deployment time from data based upon the preceding number
of days. You can use this option to specify the preceding number of days. The
system counts every day, not just the days when the lab was taken. Thus, if a lab
has not been taken for more days than the specified value then, there will be no
average deployment time.
o Show EULA: Enables/disables display of Service Terms. Service Terms are rules
with which a person taking a lab must consent. Once enabled, Service Terms are
displayed when a user first takes and lab. If the lab user consents, then the Service
Terms do not appear again for that user.
o Click here to Customize EULA: This link opens the Service Terms List page,
which lists existing Service Terms for the tenant. You can use the page to:
▪ Enable/disable a particular Service Terms.
▪ Edit an existing Service Terms.
▪ Create new Service Terms (click Create Service Terms).
o Show Full Lab Details by Default in the Catalog: Enable/disable display of full
lab details via Catalog List.
o Display VM Thumbnails: Display of the thumbnail associated on the end user lab
console in the middle tab.
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o Default Help Request Location: Sets location of student help request from
“Nested in Help Menu” or “Top Level”.
o Instructions Panel Location: Sets default location (left or right side) of the Manual
button on the instructor-led lab console.

o Open ‘Notes’ Popup On Lab Start: If enabled, then once an end user starts any lab
within this tenant, the lab console will display metadata (notes, username and
password for each VM) for the lab.
o Show Catalog: Enable/disables display of lab catalogs in Show Catalog page.
o Allow Users to See a Transcript Certificate: Enable/disable users to view lab
transcripts by clicking on an entitlement key in the Transcripts List.
o Show Default Welcome Tips: If enabled, then the lab console will display the
tenant’s default tips and display any tips created by the admin using the
Content>Tips>Create Tip option. If disabled, then the lab console will display
only the tips created by the admin but not the default tips.
o Show Estimated Deploy Time at Lab Start: If enabled, then when an end user
launches a lab, the system will display an estimated time required for the lab to
start. If not enabled, then the system will not display an estimated time required to
start the lab.
Note:
The vApp Templates list includes the Reset Average Deploy Time Statistics
option. The option clears the statistics for the selected template in order to restart
the calculation for the average deploy time.
o Show Invite Friend Links: Enables/disables display of link on lab console.
VMware Learning Platform displays the link the right tab of the lab console
within each listed lab.
o Show ‘Notes’ Button On Lab Console: If enabled, then the Notes button will be
included on the lab console for each lab within this tenant. If the end user clicks
the Notes button, then the console displays metadata such as notes, username and
password for each VM.
o Show Split Screen/Remote Control Link: Enables/disables display of link.
VMware Learning Platform supports mobile devices for split screen functionality
such that the lab’s instructional manual appears on the mobile device while the
lab console appears on a desktop or laptop.
o Show UI Walkthrough: Enables/disables the lab console walk-through tour. When
an end user starts a lab for the first time, the system automatically launches a
guided console walk-through tour/
o Show Welcome Tips: Enable/disables display of lab console Welcome Tips (per
tenant).
o Table of Contents Location: Customizes the location (“Nested in More Options
Menu” or “Top Level”) at which the lab console displays a lab manual Table of
Contents option. The following example shows the lab console when set to “Top
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Level”.

o User UI URL: URL for the user interface (for example,
https://www.vmwarelearningplatform.com)
o VM Listing Panel Location: Sets default location (left or right side) of the
Consoles button on the instructor-led lab console.

•

•

•

•

•

LTI Settings:
o LTI Consumer Key: Value for the Consumer key is specific for each tenant. This
value provides security for LTI launches. The LTI Consumer key value is a
securely generated random value by default and works similarly to API keys.
o LTI Shared Secret: Value for the Shared Secret is specific value for each tenant.
This value provides the security for LTI launches. The LTI Shared Secret value is
a securely generated random value by default and works similarly to API keys.
Note: You cannot manually enter values in the LTI Settings fields. This
restriction avoids the possibility of duplicate values across multiple tenants. You
can click Generate new LTI Consumer Key and/or Generate new LTI Shared
Secret to have VMware Learning Platform randomly generate new values.
Maintenance:
o Maintenance Mode Message: Text for message VMware Learning Platform
displays if the tenant is currently in maintenance mode.
o Maintenance Mode: Enable/disable putting the tenant in maintenance mode.
Miscellaneous:
o User Idle Countdown: Time in hours/minutes/seconds after which VMware
Learning Platform pauses user’s lab due to exceeding countdown.
o User Idle delay: Time in hours/minutes/seconds to delay pausing of a lab due to
exceeding user idle countdown.
Support Chat:
o Live Chat: Enables/disables the Live Chat option. If enabled, an end user taking a
lab can click Help>Live Chat to open a window in order to chat with support
staff.
o Live Chat URL: Chat window link (URL) of a 3rd party chat system. When an end
user clicks Help>Live Chat, the system opens the chat window.
Thresholds:
o Hit Rate Period: The View Deployment Pool page lists details of the selected
deployment pool. One of the details is “Hit”. A “hit” means a user got a pre-pop
when they requested. A “miss” means the user got a full deployment of a lab and
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probably had to wait for a long time. Hit Rate Period specifies the number of
hours for the hit rate calculation displayed in the Deployment Pool details.
Changing the hit rate period only updates the values shown on the Deployment
Pool details but the system does not actually make any substantive changes.
o Lab End Page Timeout: Time in hours/minutes/seconds. After a user completes a
lab, VMware Learning Platform will log out a user having zero credits within the
timeout specified. (Typically, a user with zero credits is at an event.)
User Hard Cap:
o Max Number of Concurrent Entitlements Per User: Limits each user to a
maximum about how many entitlements (labs) can be taken concurrently. This
field allows you to manage large online events where concurrent users can often
increase quickly and greatly.
o Max Number of Concurrent Entitlements Per User Per Lab: Limits each user to a
maximum concerning multiple entitlements to the same lab. This field allows you
to manage a student during certification. For example, a student may take a lab,
end it and, while the lab is in “awaiting grade status”, can then enroll and take the
lab again.
Note: The values you enter in the Max Number of Concurrent Entitlements per
User field and the Max Number of Concurrent Entitlements per User per Lab field
can affect a lab message.
The Custom Message section includes a lab message field called: Error message
for maximum allowed entitlement reached.
The message includes the strings {maxAllowed} and {current}. The system will
replace those strings with the values set in User Hard Cap section. For example,
the system could return the message “Only 4 concurrent enrollments are allowed
for this lab and 4 enrollments already exist.”
o Limit Number of Concurrent Users: Enable/disable cap on the number of
concurrent users per tenant. Note that this value limits the concurrent users per
tenant, taking labs. While many users can be logged into a tenant.the value does
limit the number of the users actually taking a lab.
o Alert Threshold for Active/Committed: Sets threshold for VMware Learning
Platform to send a warning to alert users if the maximum setting is being
approached.
o Committed Users per Month: Maximum concurrent users per month (for example,
a commitment of a maximum 10 concurrent users per month). This maximum
does not actually limit the number of users per month. In order to limit the
concurrent users (in the example, preventing the 11th user from taking a lab), you
would have to enable the “Limit the number of Concurrent Users” option.
Note: Committed Users per Month is not related to specific labs. Instead, the
maximum regards concurrent users in your tenant. Users will be able to take any
lab more than the maximum as long as they do not take the labs at the same time.
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Working with the User Message List
Click Security>User Messages to open the User Messages List. Use it to create/send messages
to specific end users as opposed to general messages that all users in a tenant would receive.

Creating a User Message
1. Click Security>User Messages to open a list of existing user messages for the tenant.
2. Click Create User Message to open the Create User Message form.
3. On the form, enter information for each field:
o Title: Name of the user message. Example: Test Message.
o Content: Text of the message. Example: Welcome Joe Admin and thanks!
o Enabled: Enable/disable the user message.
o Severity: Select a severity from 1 through 3.
o Send: Select Now or Later.
o Start Date: Select a start date for the message to be sent.
o End Date: Select an end date for the message to stop being sent.
o Send To: Select from Selected/All/Currently Logged In/Currently Logged In a
Lab Console. Example: Selected and the user Joe Admin.
4. Click Create. In this example, when the user “Joe Admin” opens the lab console, he
would see the following message:
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Branding Tenants
Organizations often want to brand their user interface. The branding options allows you to style
the look/feel of a lab console or tenant administration user interface with your organization's
brand.
Clicking on Tenant Management>Branding opens the Styling page. It allows you to brand
(style) the End User UI, Admin UI or event seating tickets (Event Management UI).

Preview Tab
You can preview styling changes as you make them by clicking Preview UserUI or Preview
Admin.

About the Save Button

•
•

Even though you will see your changes as you make them on the preview tabs, you must
click the Save button to actually save your styling changes. If you do not save your
changes, then your changes will be lost once you log out.
As soon as you click the Save button, anyone currently using the will see the impact of
your styling changes upon the next refresh of their screen.

Color Options
Click on one of the color options to open a palette from which you can select a color:
• Top Header Color: Styles the header area color, shown in red in the following example:

•

Top Header Accent Color: Styles the header accent color, shown in blue in the following
example:

•

Side Navigation Background Color: Styles the side navigation background, shown in
aqua in the following example:
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Primary Button Color: Styles the primary button color, shown in yellow in the following
example:

Logo
Click Browse within the Logo field to browse and load a logo.
Note: You can also click/drag a logo into the Load Logo File box. The logo you load should
conform to an aspect ratio of 188 width/44 height.

In the following example, a gold star logo has been loaded into the lab console:

Ticket Logo
Click Browse within the Ticket Logo field to browse and load a seating ticket logo. A ticket logo
refers to the logo on a seating ticket. The Event Manager UI allows an admin to print seating
tickets.
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The following seating ticket example includes a “Rainpole Systems” logo. The logo was loaded
by means of the Ticket Logo field of the Styling page.

User UI Advanced Options
Click UserUI Advanced Options to access the advanced styling options for the User UI:
• Body Background Color: Styles the User UI’s background color which is shown in
yellow in the following example:

•

Section Header Color: Styles the User UI’s section header color which is shown in red in
the following example:
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Catalog Monitor Color: Styles the User UI’s section monitor color which is shown in
aqua (Long Running Lab) in the following example:

Custom CSS
Cascading Style Sheets (CSS) files allow you customize the look and formatting of any
document written in a markup language.
Note: Any customization you make to a CSS file will be added after any of the color options you
use.
Click Custom CSS to access options that allow you to do the following:
• Edit UserUI CSS: Opens and editing tool for the User UI CSS file.
• Load a CSS File: Allow you to load a CSS file for the User UI. (You can also click/drag
a CSS file into the Load box.)
• Edit AdminUI CSS: Opens an edition tool for the Admin UI CSS file.
• Load CSS File: Allows you to load a CSS for the Admin UI. (You can also click/drag a
CSS file into the Load box.)
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Working with the Entitlement Callback List
An Entitlement Callback sends data about a just completed-lab to a contact. You can select the
type of event data you want sent back. For example, you can select to send back data about lab
start times, end times or enrollment times. The Entitlement Callback list provides options for
more targeted follow-up calls to end users from the organization conducting the lab. Once you
have configured a callback, you must associate it with a lab using the Edit Settings tab on the
Create Lab form.

Understanding Entitlement Callback Triggers
You can select entitlement events about which the system should send callback data. The Create
Callback form includes a tab that allows you select from a set of events:

To better understand the lifecycle of events and their respective boundaries, note the following
guidelines:
• Every entitlement starts with an enroll event.
• Every entitlement that an end user actually uses, has at least one start event.
• Every entitlement ends with at least one of the following events: end, expired or
canceled event.
• If an entitlement is being graded, the graded event occurs after the end event.
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Creating Entitlement Callbacks
To create an Entitlement Callback:
1. Click Integrations>Entitlement Callbacks. The Entitlement Callback List opens.
2. On the Entitlement Callback List, click Create Entitlement Callback. The Create
Entitlement Callback form opens with the Basic Info tab current.

3. In the Basic Info tab, enter the following information:
a. Enable Enable/disable the callback you are creating.
b. Global: Applies the callback to all labs in the tenant.
c. Name: Name for the callback (for example, TestEntitlementCallback1).
d. Type: Determines how the system sends the lab data:
i. URL: If you choose URL, then you will have to enter a web address,
authentication method, username/header and a password/token. Selecting
URL, results in the lab data being posted to the URL you provided. A
service can utilize that data in some manner (for example, to create
statistics).
Note: Token authentication depends upon your server and its
requirements. What you enter in the "Username/Header" field will become
the header KEY, and what you enter in the "Password/token" value will
become the VALUE. The result is customized according your web
endpoint. For example, if you were posting back to VMware Learning
Platform, then the header would be neeToken and the token would be a
long string key with the encoded username along with other such data.
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ii. Email: If you choose Email, then you will have to enter an email address
and email subject.
iii. Saba: Saba is a Learning Management System (LMS) that you can
configure for VMware Learning Platform. If you choose Saba, then you
will have to enter values for the Client ID and Client Secret fields. You
can find both those values while configuring Saba. See “ Appendix C:
Configuring and Testing a Saba OAuth Callback from VMware Learning
Platform”.
4. Click Create. The system creates your entitlement callback and opens the Edit Data tab.

5. In the Edit Data tab, enter the following data:
a. Data Type: JSON or CSV (comma-separated values) are the formats for data
returned by the callback.
b. Date Format: Date format for dates included in the data returned by the callback.
c. Fields: Select the fields that the return data should include and the date format:
i. First Name: First name of the student who took the lab.
ii. Last Name: Last name of the student who took lab.
iii. Display Name: Name as it appears in lab console.
iv. Language: Language with which student took the lab.
v. Location: Location at which the lab was launched. Currently location is
always NASA (North and South America) but that may expand to include
other geographies such as EMEA and APAC.
vi. Last Start: Date on which the student started the lab.
vii. Time Allotted: Amount of time a student is allotted to complete the lab.
viii. Time Elapsed: Amount of time that has elapsed since the student started
the lab.
ix. Expiration Date: Date on which “Time Allotted” will expire.
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x. Completion Date Time: Date on which the student completed lab.
xi. Completion Status: Status regarding whether or not the student completed
lab.
xii. IP Address: IP address used by the student that took the lab.
xiii. Return URL: Return method URL.
xiv. Extension Count: Number of times the time limit has been extended. This
value refers to “Time Allotted” for the lab. Note that the tenant’s
configuration determines whether users can extend the time limit
themselves, and how many times the users can extend the time.
xv. Master Bookmark: Value from the master bookmark for an entitlement.
The master bookmark is the “current page”, the page to which the system
takes the user upon starting the lab - so users do not have to remember
where they last were in the manual.
Note: System automatically adds/manages bookmarks having a name
starting with the characters “vlp”. The bookmarks are not always present
and thus do not manually add or edit them.
xvi. Max Step Number: Maximum step number that the user viewed in the lab
manual. Example: If a manual has 50 steps and the highest step number
the user viewed was 40, then the system returns the number 40.
xvii. Entitlement Metadata: Metadata that results from adding custom metadata
to the entitlement. You can add custom metadata by either including it as a
text string within a POST Entitlement API call or by entering text in the
Entitlement Metadata field of the Edit Entitlement tab (click
Entitlement>Entitlements to open the Entitlements List). For example,
you could include the following metadata text string to an API call:
{'metadata': This is an example of metadata'}. In
this example, the system would add the metadata “This is an example of
metadata” to the entitlement.
xviii. Lab Metadata: Metadata entered in the Callback Metadata field of the Lab
form. This metadata will be included in the returned email or URL. The
following is an example of a formatted JSON:
{
"entitlementKey": "NEE-34505_7095222167",
"account": "jsmith@vmwarelearningplatform.com",
"sku": "EDU-ICM-1400-HOL",
"tenant": "HOL",
"eventTime": "06-05-2015 12:46:38 UTC",
"event": "end",
"firstName": "John",
"lastName": "Smith",
"displayName": "John Smith",
"language": "en",
"location": "NA-WEST",
"lastStart": "01-07-2016 12:36:34 UTC",
"timeAllotted": 120,
"timeElapsed": 15,
"expirationDate": "01-07-2016 12:40:55 UTC",
"completionDateTime": "01-07-2016 12:46:36 UTC",
"completionStatus": "expired",
"ipAddress": "Unknown",
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"returnUrl": "/",
"extensionCount": 0,
"laststepcompleted": 1,
"metadata": “Test Callback Metadata”,
}

xix. Tracking Code: Used to track the link by which an end user found a lab.
6. Once you are done with the Edit Data tab, click Update. The Edit Event Triggers tab
opens.

7. In the Edit Event Triggers tab, select the events about which the system should send data:
a. Awaiting Grade: System sends data if lab is in the awaiting grading status. The
awaiting grading status is an interim status between an entitlement being started
and ended. Example:

entitlementKey,account,eventTime,event NEE-929289_82627133_,jdoe@xyz.com,
02-16-2016 13:44:27 UTC, awaiting grade

b. Enrollment: System sends data when end user enrolls into a lab. Example:
entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 22:15:50 UTC,enroll

Note: The enrollment event is not available for Saba Entitlement callbacks.
c. Complete: System sends data when end user ends a lab. This event will not trigger
a callback if the lab was cancelled. Example:
entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-11-2015 22:39:38 UTC,canceled

d. Start: System sends data when end user starts a lab (for the very first time).
Example:
entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 22:33:34 UTC,start

e. Resume: System sends data when end user resumes a lab.
Example:

entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 23:13:30 UTC,resume

f. Canceled: System sends data when end user cancels a lab.
Example:

entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 23:19:35 UTC,canceled

g. Expired: System sends data when end user reaches lab’s expiration time.
Example:
entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 22:40:54 UTC,expire

h. End: System sends data when end user ends lab. Example:

entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 22:45:51 UTC,end
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i. Exit: System sends data when end user exits lab. Example:

entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 22:50:33 UTC,exit

j. Gone: System sends data when end user’s lab session expires due to inactivity.
This event occurs when the end user did not explicitly end/exit the lab. Instead,
the lab was inactive for a prolonged period and thus the system marked the
inactivity as a gone entitlement. Example:
entitlementKey,account,eventTime,event NEE929289_82627133_,jdoe@xyz.com,01-13-2015 23:50:30 UTC,gone

k. Incomplete: System sends data when the lab is not currently active but has not
been ended. Typically, this occurs when end-user has exited the lab or has closed
the browser.
l. Ready: System sends data when a lab has been “made ready”, which means that a
deployed vApp is running in the cloud and is associated with the entitlement even
though the entitlement has not yet started. Typically, a vApp will not be
associated with an entitlement until the entitlement has started. An entitlement can
be made ready by an administrator or by an instructor, but an end-user cannot
make an entitlement ready.
m. Graded: System sends data if lab has the Graded option enabled (Edit Settings tab
of Lab form). Example:
entitlementKey,account,eventTime,event NEE-929289_82627133_,jdoe@xyz.com,
02-16-2016 13:45:28 UTC, graded

8. Once you are done selecting callback event types, click Done.
9. Click Update. The system creates your entitlement callback.

Working with Auto-Disabled Callbacks
VMware Learning Platform monitors callbacks to detect those that exceed a completion time
limit. Once a callback exceeds the time limit, the system disables it and sends a notification to
the dashboard to warn you (the tenant admin). Once a callback has been disabled, you can:
• Re-enable the callback using the Entitlement Callback form to resend the callback as
shown in the following example (SABA callback):

•

Contact the VMware Learning Platform support team to retrieve the callback data. Even
though the system never sent the callback, the data is retained in the VMware Learning
Platform database for a period of time. Thus, the support team can retrieve it for you.
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Working with the API Domain List
Open Access-Control-Allow-Origin Open API call returns can potentially be susceptible to
cross-site request forgery (CSRF) attacks. To manage this security risk, the Admin UI includes
the API Domain List.
You can add a domain to the list for a tenant integration that points to VMware Learning
Platform and that runs within a browser. If your tenant utilizes a hosted tool on a webserver that
makes API calls to VMware Learning, then you should add the domain to the list. As well, if
your tenant includes a vanity domain for a user interface, then you should add that domain into
the list.
Note the following example:
VMware Hands-On-Labs utilizes the following dashboard:
http://web.hol.vmware.com/navigator/web.hol.vmware.com
This domain makes API calls to VMware Learning Platform and thus should be added to the
domain list.

Adding a Domain to the Whitelist
To add a domain to the API Domain List:
1. Click Integrations>API Domain Whitelist. The API Domain List opens.

2. Click Create Api Domain to open the Create Api Domain form.

3. Enter a domain and enable it as shown in the following example:
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4. Click Create to add the domain to the list. The following is an example domain that has
been added to the list:

Domain List Options
You can edit, show details of or delete any domain on the Api Domain List:
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Working with the Analytics List
You can use the Analytics List to add/edit Google Analytics to your tenant.

Google Analytics Account Required
To add Google Analytics to the Analytics List, you must have first created a Google Analytics
account. Creating a Google Analytics account allows you to get an API key. You need an API
key in order to add Google Analytics to your tenant.

Adding an Analytics Service
To add an analytics service:
1. Click Integrations>Analytics. The Analytics List opens:

2. Click Create Analytics. The Create Analytics form opens:
3. On the form, select the Google Analytics service type from the pull-down.
Note: Currently, VMware Learning Platform does not support Omniture Analytics.

4. Enter you API key. The API key is a code passed to identify the calling program, its
developer, or its user to a Web site. To find the API key for Google Analytics go to the
following link: https://support.google.com/analytics/answer/1032385?hl=en

5. Click Enabled.

6. Click Create. The system adds your analytics to the Analytics List.
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Working with the Help Desk Integration List
The Create Help Desk Integration form allows you to integrate a help desk application with an
external helpdesk service.

Getting Started with Help Desk Integrations
To get started:
1. Click Integrations>Help Desk Integrations. The Help Desk Integration List opens.
2. Click Create Help Desk Integration. The Create Help Desk Integration form opens with
the Help Desk Info tab current.

a. Service: From the pull-down, select a helpdesk service with which to integrate the
help desk application you are creating.
Note: Currently, VMware Learning Platform supports only the JitBit service.
b. URL: Enter an end user URL for your application. An end user (help staff) will go
to this URL and login for example:
URL: https://rainpole.jitbit.com
c. Username: In order for you, the tenant administrator, to create a help desk
application that integrates with a help desk service, you must have an account
with the service.
Note: The system will associate the username you enter with a ticket when it is
initially created.
d. Password: In order for you, the tenant administrator, to create a help desk app that
integrates with a help desk service, you must have a password (along with a user
account) with the service.
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3. Once you are done with the Help Desk Info tab, click Create. The Custom Fields tab
opens.

a. Help Desk Ticket Category: Select a category from the pull-down. This field
maps help tickets created in VMware Learning Platform, to categories of help
tickets that exist within the service (JitBit). For example, if you select the
“Software” category, then tickets created for the help desk application you are
creating will be mapped into the Software category and be presented as such
within the service’s UI. The following helpdesk application example shows a
Software category of tickets presented within the services helpdesk UI.

b. Custom Field Mapping: Tickets created by a help desk service include fields that
describe details of the tickets. The field names the service uses are different than
those used by VMware Learning Platform. You can “custom field map” VMware
Learning Platform field names to those used by the helpdesk service. As an
example, if you were to map field names as shown:
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c. Then the helpdesk application you are creating will present the field names as
shown in the following example:

4. Once you are done with the Custom Fields tab, click Update. The system creates a
helpdesk application for your tenant and includes it within the Help Desk Integration List.
Note: System performance between VMware Learning Platform and your helpdesk
application may encounter a slowdown when the number of active issues exceeds 250.
Thus, it is recommended to start closing issues once 250 issues are exceeded.
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Working with the Entitlement List
Clicking Entitlements>Entitlements opens the Entitlements Lists. Entitlements refer to a lab’s
time limit and to valid period. The valid period is the amount of time the lab stays active. The
time limit is the amount of time that a user has, to take the lab while it is still active. VMware
Learning Platform copies values for an entitlement from the lab record when the entitlement is
created. You can use the Entitlements List to edit/manage these on a per-entitlement basis.

Action Options
On the Entitlement List, you can select one or more entitlements, then click
to
select from a pull-down:
• End: Ends an entitlement that has already started.
• Cancel: Cancels an entitlement that has not yet been started.
• Extend Time: Add more elapsed time to the entitlement(s). When you select Extend, an
entry box opens that allows you add to the remaining time.
• Reset/Remove vApp: Force the vApp in the cloud to be deleted. Thus, the next time the
user starts the entitlement, the user will get a new vApp (either a prepop or an ondemand). Reset/Remove is useful in cases when a vApp got corrupted and the best course
of action is to get a new vApp.
• Graded: This option is enabled only if the entitlement is in the “awaiting grading” status.
The awaiting grading status is an interim status between an entitlement being started and
ended.
o If a lab is not marked as requiring grading, then when it ends the system moves
the entitlement to a transcript and deletes the vApp.
o If grading is required, then the system transitions the entitlement into the awaiting
grading status and retains the vApp. The entitlement will not be active and thus an
end user (person taking the lab) cannot take or re-enroll into the lab.
o If the Graded option is enabled and you (the tenant admin) clicks it, then the
system will remove the entitlement from the awaiting grade status, copy it to a
transcript and delete the vApp.
• Make Ready: Assigns cloud resources (vApp) to an entitlement before the entitlement
initially starts. Once the entitlement is ready, the system either takes an existing prepop
from the available prepops pool or triggers an on-demand deployment. Thus, a vApp will
exist in the cloud assigned to this entitlement. The Make Ready option, allows you to
assign cloud resources to the entitlement but does not trigger the entitlement’s time
allotted time to start counting down.
• Add to Class: Adds the selected entitlements to the class you select. Once you select the
Add to Class action, the Class field appears on the Entitlement List. Thus, the steps are:
Select the Add to Class action to display the Class field; Next select a class from the
Class field.
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Editing Options
Click on an entitlement on the Entitlement List to open a form. As shown in the following
example, the form includes two tabs: Edit Entitlement and Clone Vapp.

The Edit Entitlement tab allows you to edit some of its fields:
• Time Allotted: Allots an amount of time for the selected entitlement.
• Expiration Date: Sets an expiration date for the selected entitlement.
• Score: Assigns a numerical score to the entitlement. For more information about scores,
see “Grading Options”.
• Grade String: Assigns a text grade (for example, “A”) to the entitlement. For more
information about grade strings, see “Grading Options”.
• Entitlement Metadata: Adds the metadata you enter. For example, you could include the
following metadata “This is an example of metadata”. In this example, the system would
add the metadata “This is an example of metadata” to the entitlement.
• Tracking Code: A tracking code is a useful way to track the link by which an end user
found a lab. Consider the following examples:
o A promotion campaign posts a link to a lab that includes the tracking code
promoA:
https://www.vmwarelearningplatform.com/hol/catalogs?ti
d=promoA
In this example, the system adds the tracking ID “promoA” to the entitlements of
anyone who clicked the link.
o Another promotion campaign posts a link to the same lab but instead includes the
tracking code promoB:
https://www.vmwarelearningplatform.com/hol/catalogs?tid=promoB
In this example, the system adds the tracking ID “promoB” to the entitlements of
anyone who clicked the link.
• Always Run vApp: If enabled, the system prevents the vApp from shutting down and
powering off.
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The Clone Vapp tab allows you take one vApp in a cloud and create another version of it in the
same virtual data center (vDC). As shown in the following example, you can select an
entitlement(s) and then click Clone Vapp.

Entitlement Statuses
On the Entitlement List, you can select one or more entitlements, then click
to filter the
list by entitlement status. The lifecycle of an entitlement in VMware Learning Platform includes
the following statuses:
• Complete: Legacy status which the system no longer uses. When an entitlement has been
completed, the system will move it to a transcript.
• Incomplete: Initial status of an entitlement. An incomplete status means the entitlement is
ready to be started (entitlement still has time left and has not reached its expiration date)
but is not currently active (end user is not using the lab console). An incomplete
entitlement can be in either of the following states: Just created (not started yet) or
Started but paused.
• Expired: Every entitlement has an expiration date and a time allotted. If the expiration
date is reached or the time allotted is over, then the entitlement expires. This is a
temporary status meaning that a couple of hours after expiration, the system ends the
entitlement and moves it to a transcript.
• Suspended: Not yet been implemented thus no entitlement should be in this status.
• Gone: Entitlement was active but one of the following occurred:
o End user closed the browser without first exiting or ending the entitlement.
o End user navigated away from the lab console without first exiting or ending the
entitlement.
o Internet connection on the client dropped.
o No activity on the browser console has occurred for a while and thus the system
navigated the end user an Idle page.
• Active: End user is currently using the entitlement. During an Active status, the browser
pings the server to verify a connection. If the browser drops the connection or if the
connection closes, then the ping does not occur, and the system sets the entitlement to the
next status.
• Cancelled: Similar to the Complete status. Canceled is a status of a transcript rather than
an entitlement. If an entitlement has never been started a tenant admin can cancel it. The
transcript marks the entitlement as having been canceled.
• Awaiting Grade: Only for entitlements that require grading. If an entitlement requires
grading, then, after it has been ended, the system does not move it to a transcript. Instead,
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•

the system keeps the entitlement in an Awaiting Grading status meaning that it is waiting
for a tenant admin to grade it.
Ready: Much like the Incomplete status. However, the Ready status means the system
assigned a pre-populated vApp to the entitlement. When an end user starts an entitlement
in a Ready status, then it starts without delay as the vApp is already assigned.

Grading Options
You can use the Score and Grade String fields of the Entitlement List to add grading data to an
entitlement. You can subsequently edit the grading data. To use the Entitlement List to grade an
entitlement:
1. Enter a Score or Grade String.
a. The following is an example a Score (numerical grade) entered for an
entitlement:

b. The following is an example a Grade String (text grade) entered for an
entitlement:

2. When you use the Score or Grade String fields in the Entitlement List, the system does
not actually grade the entitlement. Grading an entitlement requires transferring its grading
data to a transcript. To transfer the grading data to a transcript, you must click the
Graded option from the pull-down.

Export option
The Entitlement List includes an Export option. The Export option allows you to export all
notifications to a CSV, Excel or PDF.
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Working with the Transcript List
Clicking Entitlements>Transcripts opens the Transcript List. It lists transcripts by lab and user.
You can click, on an entitlement key to display the transcript for that entitlement.

End Type Option
The End Type option opens a pull-down that allows you to filter the Transcript List to display
only completed, cancelled or expired transcripts.

Export Option
The Export option allows you to export all transcripts to a CSV, Excel or PDF.
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Working with the Manuals List
Clicking Content>Manuals opens the Manuals List. It lists all the lab manuals associated with
the current tenant.

Creating and editing the content of an instructional manual is done with a separate application
than the Administration Dashboard you are using. The manual editing tool is called the Content
Editor. Synchronizing (Sync) is necessary to ensure that the manual you select on the Manuals
page has the exact same content in both the Administration Dashboard and the Content Engine.

Syncing Manuals
Click Sync Manuals to synchronize the manual(s) you select.
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Accessing the Content Engine
Click Content>Content Engine to access the Content Engine user interface. The Content
Engine allows an administrator to manage lab manuals. The Content Editor Reference Guide
describes how to use the Content Editor.
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Working with the Page Content List
Page Content refers to offers, announcements and promotions that appear in the Announcements
tab of the lab console. The following example shows the Announcement, “Take Labs in Your
Own Language”:

Creating Page Content
To create Page Content:
1. Click Content>Page Content to open the Page Content List.
2. Click Create Page Content to open the Create Page Content form.

o Type: Select from the pull-down: Offer, Announcement, Dashboard Promo and
Client Promo.
Note: Promos display as individual slides either on a big video screen in the
middle of an event’s showroom (dashboard promos) or on the user’s screen as a
screensaver (client promos). An example of a promo is “This lab sponsored by
our Company”.
o Enabled: Enable/disable display of page content. You can choose to enable
content for only for a certain period of time each day by using this enable/disable
toggle
o Title: Title of page content, for example “Take Labs in Your Own Language”.
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o Content: Text that appears under your title, for example “Labs have been
translated into one or more of Japanese, Chinese, Korean and Spanish”.
o Public Visible/Allow Content To Be Seen By Anonymous Users: If anonymous
browsing is enabled, then you can control which piece of content is seen by
anonymous browsers by toggling on and off. In this manner, you can control what
logged in end users see versus anonymous users.
3. Click Create.

Changing Page Content Order
You can optionally change the order of page content as it appears in the Page Content List and in
the lab console. The Page Content Order feature allows you to order individual content within
the Announcements, Offers and Promos tab. You cannot order the tabs themselves.
To change page content order:
1. Click Content>Page Content.
2. In the Page Content List, click on the first column’s header - to sort by that column,
then drag and drop a row(s). In the following example, the announcements have been
dragged/dropped in a certain order as have the offers:

The lab console will reflect the page content order within the Announcements tab and
ithin the Offers tab:
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Working with the Survey List
Click Content>Survey Configuration to open the Survey List. It lists existing surveys. You can
configure VMware Learning Platform to prompt users to go to a survey page about the lab they
just ended. The following shows an example survey page:

Creating a Survey Page
1. Click Create Survey to create a new survey.
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•
•
•

Provider: Name of the company or organization providing the survey.
URL: Link that takes end user to the survey.
Image/Browse/Upload: System can either display the survey automatically when the lab
ends, or the end user can instead click a button to launch it. The button will look like the
image file you upload. The image file you select to upload, must reside in VMware
Learning Platform’s file system.
• Enabled: Enables the survey page to display.
• Global: Enables the survey to be the global survey for the tenant.
o If an end user ends a lab that does not have a specific survey assigned to it, then
the system prompts the end user to the tenant’s enabled global survey.
o If an end user ends a lab that does have a specific survey assigned to it, then the
system prompts the end user to that survey whether Global is enabled or not.
o If an end user ends a lab that does not have a specific survey assigned to it and
you do not enable Global, then the system does not prompt to any survey.
• Auto Display: Automatically displays the survey page once the end user ends a lab. If
you do not enable Auto Display, then VMware Learning Platform includes a “Click here
for a survey” option.
• Show Survey Promotion Page: If enabled, then the lab console will display a page with
the content of Survey Promotion Page Content.
• Survey Promotion Page Content: Content of the survey (for example, “Complete the
survey for a chance to when a prize”).
The logic is as follows:
1. Lab completes.
2. If Auto Display enabled, then system displays the survey, else system displays modal
window when end user clicks the Image Link button.
3. If Show Survey Promotion Page is enabled, then system shows a page with the content
of promotional text and the Image Link button.
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Working with the Support Options List
Click Content> Support Options to open a list of existing support options. Lab consoles
include a Help option that opens a pull-down. The pull-down includes “Support Options” which
includes links to user support information. The following figure shows an example:

Creating Support Options
1. Click Create to open a page that allows you to create a new support option.

•
•
•
•
•

Name: Name of the support option you are creating. This name appears on the Support
Options List page.
Display Text: Text that appears when an end user clicks Help>Support Options in the lab
console, for example “Please visit our Hands-on Labs Online Community”
Value: An email address, phone number or URL. The value you enter must map to the
Type (email, phone, or URL).
Type: Select from the pull-down options: Email, phone or URL. The selection you make
formats the end result on the page accordingly for an email address, phone number or
URL web address.
Enabled: Enable/disable Support Options feature.
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Working with the Tip List
Click Content>Tips to open the Tips List. You can configure VMware Learning Platform to
display a tip when a user logs into VMware Learning Platform, for example:
“Did you know you that can open the User Guide by clicking the Help option which is located at
the top of your lab console?”
Note: The Edit Tenant page includes the Show Default Welcome Tips option. If enabled, then
the lab console will display the tenant’s default tips and display any tips created by you (the
admin) using the Content>Tips>Create Tip option. If disabled, then the lab console will display
only the tips you created but not the default tips

Creating a Tip
1. Click Content>Tips to open a page that lists existing tips.
2. Click Create to create a new tip.

•
•
•

Title: Name of the tip as it will appear on the Tips List page.
Tip: Text of the tip you are creating.
Enabled: Enable/disable Tips feature for the tenant.
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Working with the System Message List
Click Content>System Message to open the SystemMessage List. You can create a system
message for the User UI, the Admin UI and the Content Editor UI. The message you create popsup when a user other than you logs into the UI for which you created the message.

Creating a System Message
5. Click Content>System Message to open a page that lists existing system messages for
your tenant.
6. Click Create to create a new system message.

o Title: Name of the system message it will appear on the SystemMessage List.
o Component: Select a UI on which the message will pop up upon login: Admin UI,
User UI or Content Engine UI (Content Editor UI).
o Tenant: Current tenant.
o Enabled: Enable/disable system message feature.
o Severity: Select a severity from 1 through 3.
o Start Date: Select a start date for the message to appear.
o End Date: Select an end date for the message to stop appearing.
o Content: Use the content editor to enter the content of your message.
Once you create (click Create) your message, it will pop up on the UI you selected when
a user other than you logs in.
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Accessing Event Management
Click Events>Event Management to open the Event Management user interface. It allows you
to manage event seating and student help requests/issues. A separate guide, the Event
Management Reference Guide describes how to use the user interface.

Accessing the Proctor Interface
A proctor is someone is who is a subject matter expert about the content in the various labs.
Events often include proctors stationed in the event area. If a user has a question about a lab, the
user can then click a button (Raise Hand) on the lab console. VMware Learning Platform then
pushes the user’s question to a proctor app running on the proctor’s mobile device to notify that
someone has requested help. Click Events>Proctor Interface to open a screen that shows
messages and other information for an event.
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Working with the Help Request List
Sometimes at an event, a proctor might not be able to answer a certain question for a user. In
such a case, the proctor can click a hidden area of the user’s screen and promote the help request
to a captain. This is known as a “captain request”. A captain is typically the person who wrote or
co-wrote the lab and thus has an extensive knowledge of the content.
As well, a lab user can click on the help link in the support menu. Proctors will see such a user
help request on their Proctor dashboard or get notified by VMware Learning Platform’s proctor
mobile app. The proctor will then go help the user who made the request.
Note: When a user clicks the help request, that user’s computer gets a red, flashing border
around its screen to help the proctor identify who is requesting help.

Creating a Help Request
To create a request:
1. Click Events>Help Requests to display the Help Request List. It shows current help
requests.
2. On the Help Request List, click Create Help Request to open a form and complete the
fields.

•

Station ID: Station to which the help request is to be associated (for example,
812).
• Username: Username of the end user (for example, jsmith@rainpole.local).
• Lab SKU: Lab’s SKU (for example, HOL-1985-01-EMT).
• Captain Request: Identifies the request as a lab captain request. Refers to a proctor
clicking a hidden area of the user’s screen to promote a help request to a captain.
• State: Select from new, enroute or resolved.
• Module: Leave this field empty.
• Proctor: Associates a proctor to the request.
3. Click Create. The system creates your request and includes in the Help Request List.
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Working with the Lab Group List
At events proctors often wear a color tag associated to a category of labs. For example, a red tag
could be associated to labs about network security. Students having questions about a security
lab would know which proctor to contact.

Creating a Lab Group
To associate a color with a category of lab:
1. Click Events>Lab Groups. The Lab Group List opens.
2. On the Lab Group List, click Create to open the Create Lab Group form.

3. Enter a name, for example Security.
4. Click
to open a color chart from which you can select a color.

5. Next, select a lab from the pull-down.
6. Click Create. The View Lab Group page opens that shows the grouping of a name, color
and lab.

7. You can continue grouping a name and color to other labs using steps 1 though six.
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Working with the Account Lab Mapping List
The Account Lab Map option allows you to associate a proctor to a lab and promote that proctor
to captain. A captain is a promotion from a proctor because a captain is typically the person who
wrote, or co-wrote, the lab and thus has an extensive knowledge of the content.

Creating an Account Lab Map
1. Click Events>Account Lab-Map. The AccountMapping List opens.
2. Click Create AccountLabMapping to open a form.
3. Use the form to associate a proctor to a lab and promote that proctor to a captain:

o Account: Selects a user account.
o Assigned: Assigns selected user to be a staff member for the selected lab. The
Proctor app will not display the user as a staff member unless this option is
enabled.
o Lab: Selects a lab for the user account you chose.
o Captain: Enables promotion of the user you chose to a “Captain”.
o Alert: Enables an alert to the user you promoted.
4. Click Create.
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Working with the Lab Stats List
The Lab Stats List allows you to reset the ratings for a single lab or a collection of labs.

Managing Existing Lab Stats
Click Events>Lab Ratings to open the Lab Stats List. You can sync, view details or delete any
lab on the Lab Stats List.
1. Along an existing lab on the Lab Stat List, click
. A pull-down opens.

2. Click on an option to sync, view details or delete the lab stats.

Clearing or Syncing All Lab Stats
You can Clear All Ratings or Sync All Ratings on the Lab Stats List.
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Working with the Event ID List
An event ID is a unique key on a badge for use an event. You can use the Event ID List to view
or delete Event IDs.
• Click Events>Event ID to open the Event ID List.

•

Click
along an existing event ID on the Event ID List. A pull-down opens that
includes options to view details or delete the event ID.

•

To delete all event ID’s on the Event ID List, click Delete All.
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Working with Task Management
Tenant administration includes monitoring tasks that are running, queued, on-hold, or have failed
for your cloud org vDC.
Click Task Management to open a page that displays all long running task (any task that does
not return data instantly). The Task Management page allows you ensure that tenants are not
over-burdening the cloud. Note that the system dynamically updates task counts and the task
lists.
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Working with Dashboards
The dashboard is a great solution to keep you (the tenant admin) fully informed. You can even
create your own dashboard so as to customize the information it displays. Clicking the
Dashboards option accesses the Dashboard and Usage Graph options. VMware Learning
Platform provides you with great flexibility in selecting the type of data your dashboard(s)
display. You can:
• Select the dashboard you want to display
• Put a dashboard in Edit or Full screen mode
• Create your own dashboard
• Select a dashboard layout
• Move (click/drag) individual widgets within dashboard
• Reset dashboards
• Display a usage graph

Selecting a Dashboard
When you click Dashboards>Dashboards, the system displays the default dashboard, but you
can create your own dashboard. In fact, you can create multiple dashboards and select which
dashboard you want to display as shown in the following example:

Note: You can change the default dashboard’s layout, change/add/remove its widgets or rename
it.

Putting a Dashboard in Full Screen or Edit Mode
Dashboards include the full screen option and edit mode option:
•
•

expands the dashboard to full screen view.
puts the dashboard in Edit mode:
In edit mode you can:
o Add a widget
o Change the layout
o Delete the dashboard
o Save the dashboard
o Closes Edit Mode
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Creating a Dashboard
To create a dashboard, proceed as follows:
1. Click Default Dashboard>New Dashboard:

2. Click New Dashboard to display the Update Layout form opens.

3. In Update Layout, enter a name for your dashboard and select a layout. The layout you
select determines the number and size of panes for your dashboard. The following
example specifies the Dashboard Name MyDashboard and selects the four-column
layout:

4. Click Save. The system saves and opens your dashboard. The following is an example:
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Selecting Widgets for Your Dashboard
A new dashboard does not contain any widgets. You must select the widgets yourself and select
the type of data each widget contains. To add widgets to your dashboard, proceed as follows:
1. On the dashboard you created, click
to put your dashboard into Edit mode. In Edit
mode, the dashboard includes editing options as shown in the following example:
2. Click
to open the Add Dashboard Widgets form. Select widgets to include in your
dashboard. In the following example, Weekly Entitlement Statistics, Entitlement Time
Summary and Numeric Display are selected:

Note: The widgets available in the Add Dashboard Widgets form depends upon your user
role. For example, an instructor role accesses fewer widgets than an admin role.
3. Click Add Widgets (Add 3 Widgets in the example). The system displays the dashboard
with the widgets you selected as shown in the following example:
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Configuring Your Widgets
A widget you add may need configuration. In the example, the Numeric Display widget requires
configuration. To configure a widget or change the existing configuration, proceed as follows:
1. Click on a widget to open a widget configuration form.
2. Specify a configuration as shown in the Numeric Display Config example (Widget
Name, Layout and Selected Counts):

3. Click Add, then click, Save. The system displays your dashboard with the newly
configured widget.
Note: Some widgets include only option, which deletes the widget.

Changing the Layout of a Dashboard
You can change an existing layout by doing either of the following:
• Clicking/dragging widgets. The following example shows the widget
MyNumericDisplay being dragged within its dashboard:

•

Click

to open the Update Layout form. Use it to select a different layout.

TENANT ADMINISTRATOR REFERENCE GUIDE /120

Tenant Administrator Reference Guide

Working with Widgets
A dashboard includes lots of widgets types that you can select.
1. On the current dashboard, click
to put your dashboard into Edit mode. In Edit mode,
the dashboard includes editing options as shown in the following example:
2. You can add any of these widgets by clicking
form:

to open the Add Dashboard Widgets

About the Notifications Widget

Features
The Notifications widget is probably the most informative and configurable and thus requires the
most explanation. It includes the following features:
• Severity Levels: Green (low), orange (medium), or red (high).
o High severity notifications regard issues impacting multiple users and often across
multiple tenants. Typically, a high severity notification stems from a cloud being
unavailable.
o Medium severity notifications issues mean someone is unable to use the system
(examples include failure to start labs or errors deploying vApps).
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o Low severity notifications typically regard information such as daily summaries.
Note: You can click on one of the severity notifications color symbols (
)
to display only notifications of that severity. For example, if you click
, then
only the red (high severity) notifications are displayed.
• Subscription: While notifications appear on a dashboard, the system is still capable of
sending an email. Click Subscription to open the Notifications Subscription List. From
there, you can add an email address and set criteria for which the system should send out
notifications. Once you define a subscription, each time a notification that meets your
criteria occurs, the system will email it to everyone who has subscribed, as well as
showing it on the dashboard.
Note: In the Notifications Subscription list, severity levels are represented as 1, 2, 3 (1=
Red; 2=Yellow; 3=Green).
• Archive: Displays the Notification Archive List which lists all archived notifications.
Note: The Notification Archive List includes an Export option. The Export option allows
you to export all notifications to a CSV, Excel or PDF.
• Acknowledge All: Archives all notifications. Once you archive a notification, it will no
longer be displayed on the dashboard. You will have to follow the archive link at the top
to view acknowledged notifications.
Archive and Subscription
You may find it useful to:
1. On the Notifications widget, click Archive to open the Notification Archive List.
2. On the list, find notifications that are of interest to you. For example, you might be
interested in cloud notifications.
3. Click Dashboards>Dashboards to reopen the dashboard.
4. On the Notifications widget, click Subscription to open the Notification Subscription
List.
5. On the list, click Create Notification Subscription to open a form.
6. On the form, enter an email address, a notification category, a severity and check the
Enabled box.
7. Click Create. The system will send an email each time a notification that meets the
criteria occurs
Categories
Notifications are categorized as follows:
• Default: Refers to a default category
• Cloud: Refers to cloud errors
• Administrative: Refers to administrative notifications
• cloudVapp: Refers to cloud errors.
• System: Refers to general system errors.
• genericTask: Refers to non-cloud related tasks (for example, a bulk import)
• prePop: Refers to pre-popping of lab errors.
Sub-Categories
Notifications are also sub-categorized to form the following category/sub-category pairings:
•
•
•

administrative,myLearn
cloud,connection
cloud,sync
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•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

•

cloud,task
cloudVapp,""
genericTask,massUpload
genericTask,task
genericTask,userDownload
genericTask,userMove
prePop,"Daily Summary"
prePop,"provision failure")
system,monitoring
administrative,myLearn
cloud,connection
cloud,deployment
cloud,sync
cloud,task
cloudVapp,""
genericTask,emailTranscipt
genericTask,massUpload
genericTask,statsDownload
genericTask, task
genericTask,userDownload
genericTask,userMove)
prePop,"Daily Summary"
prePop,"provision failure"
system,cloud
system,monitoring

About the Download Entitlement Statistics Widget
The Download Entitlement Statistics widget generates a csv file report of entitlement statistics.
The report includes the following fields: username, firstName, lastName, company, labId,
entitlementId, entitlementStart, entitlementEnd, entitlementComplete, exitCount, totalTime,
stepNo,language.

Editing Widgets
You can change the configuration settings for some widgets on a dashboard. To do so, you put
the dashboard into Edit Mode, then click to open a form. For example, to change the
configuration settings for the Cloud Capacity Usage widget:
1. On the dashboard, click to activate Edit mode:
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2. On the Cloud Capacity Usage widget, click

to open its form:

3. On the form, reset the Warning Threshold Percent and Critical Threshold Percent.

4. Click Save.

Resetting Dashboards
The Reset All Dashboards option deletes any admin-created dashboard and restores the default
dashboard. In the following example, the Reset All Dashboards option would delete
MyDashboard and restore the default system dashboard.

Usage Graph
Click Dashboards>Usage Graph to open the Usage Graph. The Usage Graph shows the
number of concurrent labs used by the tenant during the current or previous month.
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Working with Instructor-Led Labs
Setting up an instructor-led lab involves the following sequence of tasks:
1. Using the Edit Account form, assign an existing user the role of Tenant Instructor. Users
assigned this role will appear in a list accessible from the Create Class form. A tenant
instructor can monitor the progress of selected students (a class) taking a specified lab
(instructor-led lab).
2. Using the InstructorLabMapping List to associate tenant instructors with specific labs. By
creating such instructor-lab associations, you can restrict tenant instructors to access only
specific labs. If you do not create any instructor-lab associations, then no instructor
restrictions will exist, and tenant instructors will be able to access any lab in the tenant.
3. Using the Create Class form, create a class. A class is comprised of selected users
(students) to take a specified lab, at a specified time and to be monitored by a specified
instructor.
4. Tenant instructor, by means of the Instructor Console, monitors the progress of each
student in a class who has started the lab specified in the class.

Creating Instructor-Lab Associations
To create an instructor-lab association:
1. Click Classes>Instructor-Lab Map to open the InstructorLabMapping List.

2. On the InstructorLabMapping List, click Create InstructorLabMapping. The Create
InstructorLabMapping form opens.

3. Complete the fields of the form:
a. Account: Allows you to select a user from an account list. Select a user having a
Tenant Instructor role.
b. Labs: Allows you to select lab(s) from a labs list. Select lab(s) with which you
want to associate the tenant instructor you selected.
4. Click Create. The system creates an association between the tenant instructor you
selected and the lab(s) you selected. This association restricts the tenant instructor’s
access only to the lab(s) you selected.
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Creating a Class
To create a class:
1. Click Classes>Classes to open the Class List page.

2. On the Class List, click Create Class. The Create Class form opens.

3. Complete the fields of the form:
a. Class SKU: Similar to an SKU, this field identifies the class you are creating. An
example of a Class ID is “Network Security101”.
b. Name: Text string associated to the class you are creating. An example is
“Introduction to Network Security”.
c. Description: Text string to provide a brief description of the class you are
creating.
d. Notes: Text providing additional information about the class you are creating. An
example of such text is “Students should a have a basic understanding of
computer networks”.
e. Enabled: Enables/disables the class you are creating. This field must be checked
(enabled) to make the class you are creating available.
f. Start Date: Select a start date/time for the class you are creating.
g. End Date: Select an end date/time for the class you are creating. The end date you
enter must be later than the start date you entered.
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h. Pre-Provision Period: Point in time before the class’s start date at which the
system should start making pre-pops for the class. A pre-provision period avoids a
student having wait for a vApp to power on when the lab is launched.
i. Lab: Select an existing lab. This is the lab the students will be taking at the
specified date/time.
j. Number of Seats: Currently, this field is non-functional and thus does not impact
instructor-led class behavior or prepop behavior.
k. Students: Select existing users who you want to include in your instructor-led lab.
The number of students you select does not have to match the Number of Seats
field. For example, you can enter a Number of Seats value of 10 and select only
five students.
l. Instructors: Select a user(s). Only users who have been assigned the role of
“Tenant Instructor” are included in the list from which you make your
selection(s).
4. Click Create. The system adds your class to the Class List. A tenant instructor can now
go to the Class List, select the class you created and launch the Instructor Console. From
the Instructor Console, an instructor can monitor students of the class as they take the lab
and even take over a given student’s lab console. See the Tenant Instructor Reference
Guide for a description of the Instructor Console.
Note: The Edit Tenant page includes the option “Allow Instructors Access To All
Classes”. If enabled, then an instructor can go to the Class List and view all the classes in
the tenant. If disabled, then the Class List lists only those classes to which the instructor
has been assigned.

Editing an Existing Class
You can edit an existing class by selecting it from the Class List. Selecting a class opens a form
that includes three tabs:
• Edit Class: Allows you to edit the basic information fields for the class.
• Student List: Displays a list of the students comprising the class.
• Entitlement List: Allows you to add/remove entitlements from the existing class.
Note: These changes will trigger a refresh of the instructor console and a refresh
notification:
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About Single Action Options
The Class List includes a pull-down whose options impact only the single class selected as
shown in the following example:

Mass Action Options
The Class List includes a Mass Action pull-down. First, select the classes you want to take a
mass action upon, then click the down arrow to open the pull-down:

•
•
•
•
•
•

Create Entitlements: Creates lab entitlements for students in the selected classes but does
not enable them. Thus, until enabled, a student’s lab console will not list the entitlements
in the Enrollments tab.
Enable Entitlements: Enables the created entitlements for the selected classes.
Provision Entitlements: Powers-up the vApps for each entitlement (manually triggered
pre-pop) for the selected classes.
Start Class: Creates, enables and provisions the selected classes. Also sets the statuses of
the selected classes to “Active”.
End Class: Sets the statuses of the selected classes to “Complete” which will archive
them and prevent further updating.
Delete Class: Deletes the selected classes form the Class List.
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About Class Bulk Upload
The Class List includes an option to upload many (bulk) users at once by means of a CSV file:

The following procedure is an example of uploading bulk classes:
1. Click Class Bulk Upload to expand the option. It includes three tabs and defaults to
Upload CSV:

2. Click Browse to select a CSV file as shown in the following example:

Note: You can optionally click
to open the File upload format information page.
Along the bottom is the Download Sample of CSV option. It downloads a sample csv file
that is useful to gain an understanding of the file format the system expects.
3. When you are done with the Upload CSV tab, click Next. The Preview tab opens.
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4. Once you have verified your bulk upload, click Finish. The system creates the classes
included in your CSV file. Remember to refresh your Class List.
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Troubleshooting
Clicking on Troubleshooting takes you to a VMware Learning Platform support page.
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Appendix A: Cloud Placement Algorithm
VMware Learning Platform uses a placement algorithm to determine where vApp deployments
should be made.

Input/Output
Note the following about input/output to the algorithm:
• Input: One or more vApp templates and a request to place one or more vApps.
• Output: Either an error response if the placement is not possible or an indication of which
vDCs and which templates should be used, and how many vApps should be placed in
each.

Configuration Options
The algorithm relies on a number of configuration options that can have some impact on the
output. The general algorithm is the same regardless of the current configuration. Similarly, the
inputs dictate the possible outputs. However, the algorithm also recognizes a single special case.
The special case occurs when just one vApp is being placed, which changes the way the
algorithm selects the outputs. When placing multiple vApps, the algorithm tries to find a fair
distribution of vApps across all the available resources. In the special case of placing a single
vApp, the algorithm instead tries to place the vApp in the vDC that will make the vApp available
in the shortest possible time.

Methodology
The algorithm starts out with one or more vApp templates which can be used interchangeably to
deploy the requested number of vApps. From this initial list of templates, the system locates all
the vDCs in which it may be possible to place a vApp. Possibilities include the following:
• All the vDCs to which the templates belong
• Any vDC that shares storage with a vDC that owns one of the templates, and therefore
has access to the template and any vDC that has a shadow copy of any of the initial
templates.
From this collection of vDCs, the system removes any that are not currently available for
deployments due to the current configuration. The storage usage for the vDC is then checked.
Any vDC whose current storage level is above the configured threshold in VMware Learning
Platform is ruled out. For the vDCs still under consideration, the system calculates a current
“resource utilization” score based on the current amount of memory and CPU in use relative to
the limits configured for that vDC. This utilization score is compared to the configured usage
threshold, and any vDC whose utilization is above the threshold is noted – although not ruled out
at this point.
The final piece of information collected for the vDCs still under consideration is any outstanding
work that VMware Learning Platform has already assigned to the vDC. Note that this will not
rule out any vDC but does factor into the calculations for assigning deployments.
If the algorithm is placing a single vApp, then at this point the algorithm has enough information
to determine which vDC is likely to produce the fastest deployment. That vDC will be selected
and the process then complete.
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When placing multiple vApps, VMware Learning Platform generally considers all the available
vDCs roughly equal and tries to evenly distribute the vApps across all available vDCs. The
exceptions to even distribution are:
• If it has reached it storage limits, then a vDC will no longer be used
• If placing new vApps in that vDC would push it past its storage limit
Deployment to a vDC will also be scaled back when its utilization score moves past its threshold.
In this case, the number of vApps assigned to that vDC will be scaled back from what would be
an even distribution by an amount dependent on how far past its utilization threshold the vDC
has gone. The extra vApps will be assigned to other vDCs.
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Appendix B: Setting Up a 3rd Party Learning Application
Overview
Assume the education department of your organization wants an integration to a learning
management system (LMS) such that the LMS becomes the system of record, controls access to
the lab and records the usage and completion of the lab. VMware Learning Platform supports
such an integration.

Terminology
•
•
•

Learning Tools Interoperability (LTI): Standard set of specifications for allowing third
party learning applications (or "tool providers") to integrate with educational platforms
(or "tool consumers").
Learning Management System (LMS): Software application for the administration,
documentation, tracking, reporting and delivery of electronic educational technology (elearning) courses or training programs.
Moodle: Learning platform designed to provide educators, administrators and learners
with a single robust, secure and integrated system to create personalized learning
environments.

About Moodle
VMware Learning Platform supports integration to any LMS that supports LTI/LIS and supports
custom integrations of other systems using a robust API and lab callback feature. The procedures
in this appendix assume Moodle as an LMS. The procedures to set up LTI launches will be
similar for any other LMS.
Note the following about Moodle:
• Moodle is open source and freely available.
• Directions to install Moodle can be found at: https://download.moodle.org
• In LTI terms, VMware Learning Platform is considered the LTI Tool Provider and is
configured as an external tool. The LMS (Moodle) is considered an LTI Tool Consumer.
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Getting Started
To get started, you must add VMware Learning Platform as an external tool. Doing so involves
completing the following tasks:
1. Installing Moodle.
2. Logging into Moodle.
3. Configuring an external tool.

Installing Moodle
To install Moodle:
1. Point your browser to the following URL: https://download.moodle.org/
2. Follow the instructions to install Moodle on your machine.

Logging into Moodle
Once you have installed Moodle, login as an “admin”. Typically, the default admin credentials
are as follows:
•
Username: admin
•
Password: 12345
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Upon a successful login, you should see an Online Users box that identifies you as user "Admin"
as shown in the following example:

Configuring an External Tool
Your next task is to configure an external tool. Essentially, configuring an external tool provides
Moodle with the information it needs to integrate with VMware Learning Platform. Proceed as
follows:
1. In Moodle, use the left panel to navigate to the Manage Tools page:
Site administration > Plugins > Activity modules > External tool > Manage tools
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2. On the Manage Tools page, click Configure Tool Manually to open the External Tool
Configuration form.

3. On the External Configuration form, enter values within the Tool Settings section. The
following are example values:
Note: You can click Show More… to expand the Tool Settings section.
a. Tool name: Rainpole Edu
b. Tool base URL: https://core.vmwarelearningplatform.com/lti/launch
Note: The VMWare Learning Platform cartridge link is the core domain with the
"/lti/cartridge" path.
Note: If your LMS does not support a custom parameter, then you must include
the lab code as the last segment in the URL. For example, if the lab code is
lab=Rainpole, the URL would be:
https://core.vmwarelearningplatform.com/lti/launch/Rainpole
c. Tool description: Integration to Moodle
d. Consumer Key: 12345
e. Shared Secret: 1234567890
Note: Values for the LTI Consumer Key and Shared Secret are tenant options in
VMware Learning Platform and are specific values for each tenant. These values
provide security for LTI launches. Consumer Key and Shared Secret values are
securely generated random values by default and work similarly to API keys. In
the VMware Learning Platform Admin UI, you can find the values in the View
Tenant page (Tenant Management>Tenant Info).
f. Tool Configuration Usage: Show in activity chooser and as a preconfigured
tool
g. Default Launch Container: New Window
h. Icon URL: https://core.vmwarelearningplatform.com/images/lti-icon.png
i. Secure icon URL: https://core.vmwarelearningplatform.com/images/ltiicon.png
Note: The icon URL and secure paths point to an icon that Moodle can use as a
kind of logo for your integration as shown the following example:
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4. In the Privacy section, make the following changes:
a. Share launcher’s name with tools: Always
b. Share launcher’s email with tool: Always
c. Accept grades from the tools: Always
The following is an External Configuration form with the example values:
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5. Click Save Changes. You have now globally configured a VMware Learning Platform
tool for the LMS. Moodle's Manage Tools Page should include a tool (Rainpole Edu) as
shown in the following example:

Launching Your Lab
Now that you have added an external tool, you must complete the following tasks to launch a lab
from Moodle:
1. Add a new course.
2. Add the tool, which you configured in the previously, as an activity.
3. Enter an LTI parameter value into Moodle.
4. Create a user in Moodle.
5. Enroll the user you created in a course.
6. Log in as the user and launch a lab.
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Adding a New Course
A course in Moodle is an entity to which you can add resources and activities for students to
complete. In this example case, the activity would be the tasks in the lab already in a VMware
Learning Platform tenant. To add a new course, proceed as follows:
1. On the navigation side panel, click All courses.... to open the Courses page.

2. On the Courses page, click Add a new course to open the Add Course form.
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3. On the Add Course form, enter information only for the required fields. The following
are example values for the required fields:
a. Course full name: Rainpole Lab
b. Course short name: Rainpole Lab

4. At the bottom of the form, click Save and return. The system should display the course
you added (Rainpole Lab) as shown in the following example.
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Adding the Tool as an Activity
Now that you have added a course, your next task is to add your tool (Rainpole Edu) as an
activity:
1. Click on the course you added to open the course's page. In the following example,
Rainpole Lab is the course you added.

2. On the course's page, click Turn editing on.

3. Click Add an activity or resource to open a form.
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4. On the form, enable the activity. In the following example, Rainpole Edu is the activity.

5. Click Add. You have now added the activity. The Adding a New External Tools page
opens.
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Entering an LTI Parameter Value into Moodle
To identify the lab, you want to launch from Moodle, you must specify the lab's LTI Parameter
value. Proceed as follows:
1. On the Adding a New External Tool page, enter a value in the Activities field (Rainpole
Edu in the example).
2. In the Customs parameters field enter a value (lab=Rainpole in the example). This LTI
Parameter value identifies the lab you want to launch from Moodle.
Note: In the VMware Learning Platform Admin UI, the LTI Parameter value is included
in the Lab List.
Note: If your LMS does not support a custom parameter field, then you must include the
LTI parameter (lab code) as the last segment in the URL within the External
Configuration form, Tool base URL field. For example, if the lab code is lab=Rainpole,
then in the External Configuration form you would enter the tool base URL:
https://core.vmwarelearningplatform.com/lti/launch/Rainpole

3. At the bottom of the page, click Save and return to course. You have identified the lab
you want Moodle to launch.
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Creating a User in Moodle
Now that you have specified the lab you want to launch from Moodle, you must create a user.
This is necessary because typically an organization's education department (Rainpole Edu in the
example) wants the LMS to be the system of record, control access to the lab and record the
usage/completion of the lab. An education department would not want students going into the
catalog in VMware Learning Platform to run the lab. Instead, an automatic completion status
sent to the LMS is preferred to avoid students having log into two different systems.
To create a user in Moodle, proceed as follows:
1. On the navigation panel, go to Site administration>Users>Accounts>Add a new user
to open a form.
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2. On the form, enter values for the required fields. The following are example values:
o username: eferrari
o password: VMware1!
o First Name: Enzo
o Surname: Ferrari
o Email address: eferrari@rainpole.local

3. Click Create User at the bottom of the form. The system displays the Users page. It lists
the user you just created as shown in the following example.
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Launching the Lab
Now that you have created a user, you must enroll that user into your course. Once you have
enrolled the user, you can log in as that user and launch the course. Proceed as follows:
1. On the navigation side panel, go to Current Course>Rainpole Lab>Participants to list
all participants. (Rainpole Lab is the example lab.)
2. On the list, click the Gear next to the All Participants heading. The system opens the
Enrolled users list.

3. On the list, click Enrol users. The system opens the Enrol users form.
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4. On the Enrol users form, click Enrol next to the user you created.

5. Still on the Enrol Users form, click Finish enrolling users. The system returns to the
Enrolled users list.
6. On the list, click on the image box of the enrolled user as shown in the following
example. The system opens the user's profile.
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7. On the profile, click Log in as to log in as the user as shown in the following example:

8. If the system displays the "You are logged in as" page, then click Continue. The system
displays a link to lab you want launch.

9. Click the link to launch the lab from within Moodle as shown in the following example.
The system launches the lab you configured in VMware Learning Platform.
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Integration Notes
How does the LTI launch work in VMware Learning Platform?
An LTI launch utilizes Oauth. The LTI launch includes the consumer key, a nonce, a timestamp,
and a signature using the shared secret. For authentication, VMware Learning Platform first
looks up the tenant based on the consumer key. Next, the nonce and timestamp are verified.
VMware Learning Platform keeps track of nonces used by each tenant. Each launch follows the
API documentation’s recommendation for external tool provisioning. The user account is entitled
to the lab and then the entitlement is started.

What about VMware Learning Platform Classes?
The 3rd party integration also supports configuring a VMware Learning Platform class. The
tasks to do so are similar as for a common lab. However, you would have to specify the class
sku. If you were to try to start the class from Moodle, the integration would check if the class
exists in VMware Learning Platform. With a successful class launch, the instructor would see the
students from Moodle in the instructor console just as would be the case in VMware Learning
Platform.
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Appendix C: Configuring and Testing a Saba OAuth Callback
from VMware Learning Platform
The following instructions allow you integrate Saba and OAuth into VMware Learning Platform.

Terminology
•
•

Saba is a Learning Management System (LMS). An LMS is a software application for the
administration, documentation, tracking, reporting and delivery of electronic educational
technology courses or training programs.
OAuth is an open standard for authorization, commonly used as a way for internet users
to authorize websites or applications to access their information on other websites but
without giving them the passwords.

Configuring Saba
1. Log into Saba as an admin:
a. Go to: https://myvmware-stg.workspaceair.com
b. Login as an admin. The Workspace One apps desktop opens.
c. Select Hive Dev. The Hive page opens.
2. Retrieve the Client ID/Secret:
a. On the Hive page, click Admin.

The Admin page opens.
b. From the Admin page, navigate to the API Dashboard: System>Manage
Integrations>API Dashboard
c. Copy the values for the Client ID and Client Secret into the OAuth section. You
will use these values later for setting up a callback.
d. If the Client Secret is empty, then click Generate at the bottom of the OAuth
section to create a new Client Secret.

e. Copy the URL next to the API Dashboard header (for example,
https://vmwareqa-api.sabacloud.com). You will use this URL for setting
up a callback.
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3. Configure VMware Learning Platform as a vendor. (This step is not necessary if VMware
Learning Platform has already been setup as a vendor.)
a. Click Admin to return to the Admin home page.

b. From the Admin Home page, navigate to the New Content Vendor page:
Learning>Manage Content>Content Vendors>New Content Vendor

c. On the New Content Vendor page:
i. Top section: Enter necessary fields.
ii. Vendor Integration Model section:
1. Set Vendor Type to LAB.
2. Enter VMware Learning Platform tenant admin credentials for
Customer ID and Password.
3. Enter the User URL.
Note: These URLs must be publicly accessible and cannot be
localhost URLs.
Note: The URLs must have the following format:
http<s>://<domain>/console?neeToken=
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iii. Enter the Core URL for the Enroll URL. The URL must have the
following format: http<s>://<domain>/?tenant=<tenantname>
The following is an example screen:

iv. Click Test URL to ensure the communication functions.
v. Click Save.
4. Configure a VMware Learning Platform lab as Content on Saba.
a. Click Admin to return to the Admin home page.

b. From the Admin Home page, navigate to the Content Library:
Learning>Manage Content>Content Library
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c. In the Content Library:
i. Click the folder under which you would like the content to appear. (Create
a folder if necessary.)
ii. Click the Import (on the right next to the Contents header).
iii. Enter a name for the lab.
iv. Set the Content Format to LAB
v. Set the Content Provider to the vendor you selected in Step 3. (That is, set
VMware Learning Platform as a vendor.)
vi. Retain the Player Template as New Window Standard Template.
vii. Click Next.
viii. Enter the lab SKU in the Lab Code field.
ix. Click Verify Code to ensure that the lab code exists and is connected.
The following is an example screen:
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5. Configure the VMware Learning Platform Lab Content as an Activity in the Learning
Catalog.
a. Click Admin to return to the Admin home page.

b. From the Admin Home page, navigate to the Learning Catalog:
Learning>Manage Learning Catalog>Learning Catalog to open the Learning
Catalog screen:

c. On the Learning Catalog screen:
i. Click New Catalog Item to open the following screen:

ii. Click Online Course (under the Quick… header) to open the New Course
– Basic Information screen:
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iii. On the New Course – Basic Information screen, enter a title, then click
Save & Next to open the New Class screen:

iv. On the New Class screen, click Save & Add Activities to open the
Activities screen.

v. On the Activities screen, set the Add Activity dropdown to Content.

vi. Still on the Activities screen, ensure the Search existing content radio
button is enabled.
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vii. Enter the name of the Lab created in Step 4 (Configure a lab as Content on
Saba) into the field under Search existing content. The following is an
example screen:

viii. Click Add (on the right) to open a modal.

ix. On the modal, click Save to open the next screen.
x. On the screen, click Publish (on the bottom right).
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Configuring a VMware Learning Platform Callback
1. Log into the VMware Learning Platform Admin UI:
a. Go to: https://core.vmwarelearningplatform.com
b. On the login screen, login as a tenant admin
2. On the Admin UI, click Labs/Catalog Info>Callbacks
Callback page opens.
3. On the Callback page, click Add a New Profile.
Callback wizard opens.

4. On the Add a New Profile wizard:
a. Enter a Name for your callback.
b. Mark your callback as Global (if you do not mark it as Global, then you will
have to add your callback to the specific lab set up earlier).
c. Select Saba as the Return Method.
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d. In URL field, enter the URL from Step 2 with the path:

/v1/partner/reportResult
(Example, https://vmwareqaapi.sabacloud.com/v1/partner/reportResult)

e. Enter the Client ID and Client Secret from Step 2 into the corresponding fields
f. Enter the Username and Password for Saba.
Note: These credentials are stored in the Callback table in VMware Learning
Platform. If someone is able to access the database, that person will have
those credentials and will be able to log into to Saba. Thus, it is best to use an
account that is locked down to API access for the reportResult endpoint.
Additionally, you should encrypt the client
id/secret/username/password fields in the database.
g. Click Next (bottom-right of wizard tab) to move to the next tab of the wizard.

5. On the new wizard tab (2 of 4), choose the optional fields you would like to return
and then click Next to open the next tab of the wizard.

6. On the new tab of the wizard (3 of 4), click Next as this tab just for consistency and
information purposes. The last tab of the wizard opens.

7. On the last tab (4 of 4), choose the events about which you would like to send data.
8. Click Save (bottom of the tab).
Note: For more information about Callbacks, see the section “Working with the
Entitlement Callback ”.
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Testing Your Callback
Test your callback on a separate browser or incognito window to avoid possible collision with
login cookies.
1. Log into Saba:
a. Go to: https://myvmware-stg.workspaceair.com
b. Login as an admin. The Workspace One apps desktop opens.
c. Select Hive Dev. The Hive page opens.
2. Search for the catalog you created during Step 5 by entering the name of the catalog
in the top right search box.
3. Click Enroll. The VMware Learning Platform lab should open in a new window.
Note: A 10-second timeout from Saba occurs in order obtain the Nee-token needed to
launch the lab. If your Core does not respond in time during entitlement, then Saba
will show a Socket Connection timeout error.
4. Start the lab, and then end it.
5. Close the VMware Learning Platform Lab window.
6. Close the Saba Content Modal.
7. Verify that the Status of the lab is “Completed successfully”. If so, your callback has
worked properly.
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Details/Notes
•

•

•

•

Oauth2 is a flexible spec. There are a good number of attack vectors, especially when
refresh tokens never expire which is in Saba’s implementation. Do not allow any
credentials leaks. Ensure the Saba user/password you are using in VMware Learning
Platform has proper lock downs on Saba to mitigate impact of leaking those credentials.
VMware Learning Platform caches access token/authorization code in the
SabaOauthClientCredential domain. These run repeatedly until there is an error when
calling the Saba API. If there is an error when calling the Saba API, then the cached
token/code are cleared from the database and new ones are retrieved. If there is an error
retrieving new token/code, a debug message logs and an error message returns through
the CallbackService chain to consistently behave as URL and Email errors.
Saba API specifies that the refresh token should be used to retrieve a new access token.
This refresh token never expires. It is possible that the refresh token could become
invalid and that adding this refresh logic could complicate the code. Thus, instead of
using the refresh token, the callback will use the stored Saba username/password to get a
new access token when necessary.
A 10-second timeout on lab launch from Saba creates difficulty when developing locally
to setup debug breakpoints. You can setup an Amazon instance with all the necessary
requirements and three virtual apache/tomcat hosts for core, user-ui, and web socket.
Doing so opens up remote debug to hook up breakpoints via IntelliJ. Contact VMware
Learning Platform technical staff if you want the AMI and instructions.
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Appendix D: Creation of Multiple Network Bridges to Link
vApp Network with vDC network
VMware Learning Platform supports the creation of one or more network bridges. This support
is necessary in to link a vApp network with a vDC network while deploying a vApp. Further,
this support requires that the vApp template had been captured from a vApp that had networking
fully configured, including all the preferred settings. For example, if NAT is required, then it
must have been configured and working when the vApp was captured to the catalog.
To have VMware Learning Platform link networks, pairs of metadata entries should be added to
the vApp template in the vCD. This indicates (to VMware Learning Platform) which networks
should be joined. The system uses the values of the metadata to match network names. This is
how VMware Learning Platform knows which networks to bridge. A special metadata key/value
entry can also be set for the vApp template to disable VMware Learning Platform networking,
overriding the other settings used to setup network bridges.
VMware Learning Platform uses the name of the key in the metadata key/value entry to
determine if the metadata contains information about networking configuration. If the metadata
key starts with either the string vappNetwork or the string orgVdcNetwork, immediately
followed by an integer, then VMware Learning Platform will consider the metadata entry to be
about network configuration and will use this metadata to configure networking. The value
vlpNetworkingDisabled can also be used to disable network configuration (note that the
string neeNetworkingDisabled is still supported as a synonym for
vlpNetworkingDisabled for backwards compatibility).
If a vApp template has a metadata key/value entry where the key is
vlpNetworkingDisabled (or neeNetworkingDisabled) and the lower-case
representation of the value is the string True, then no networking will be setup for the vApp.
This behavior overrides all other networking setup.
To join a vApp network to an org vDC network, the metadata entries should be defined in pairs,
where a “matching pair” of metadata entries are defined with keys ending with the same integer
value. Examples of matching pairs are: vappNetwork1 and orgVdcNetwork1 or
vappNetwork05 and orgVdcNetwork05. The numerical components of the name are used
to identify the pair of keys that should match, thus different pairs of metadata (if there is more
than one pair) need to have unique numbers within the vApp, but these different numerical
values do not have to be consecutive integers.
The values of the metadata pairs are used to identify the networks to be bridged, with the
vappNetwork metadata value identifying the vApp network and the orgVdcNetwork metadata
value identifying the vDC network. These entries should have values that VMware Learning
Platform can match with the names of the vApp network and vDC networks to determine which
should be bridged.
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When VMware Learning Platform has matched the pairs of metadata values defining the
networks that should be bridged, the networks are bridged one pair at a time.
When matching the value of the vappNetwork metadata value with a vApp network, VMware
Learning Platform examines the names of all the vApp networks available for the vApp and
selects one where the name contains the string from the value of the metadata. This is a casesensitive match. Thus, a network named vAppNetwork01 would be matched by the metadata
value vAppNetwork01 or the metadata value Network01 but will not be matched by
metadata value vappNetwork01 as the strings have different case. If more than one network
matches the metadata value, a random network will be chosen. If no network matches the name,
this metadata pair will not result in a network being bridged.
When matching the value of the orgVdcNetwork metadata value with vDC networks, VMware
Learning Platform examines the names of all the vDC networks available in the vDC and will
select the network whose name starts with the value of the metadata entry. This match must be at
the beginning of the network name and is not case-sensitive. For example, the metadata value
vDCnetwork-01 will match the network named vdcNetwork-01-vdc01 and will not match the
network named ignore-vDCnetwork-01-vdc1. If more than one vDC network is matched, or if
none are matched, networking will not be configured for this metadata pair.
When all pairs of networking metadata have been processed, the networking setup is complete.
As an example, if a vApp template defines three vApp networks named net01, net02 and net03,
and can be deployed into one of two vDCs named vdc1 and vdc2, where vdc1 has networks
named internal-net01-vdc1, external-net01-vdc1, notused-network-vdc1, while vdc2 has
networks named internal-net01-vdc2 and external-net01-vdc2, then the following metadata could
be added to the template:
vappNetwork5=net01
orgVdcNetwork5=internal-net01
vappNetwork6=net03
orgVdcNetwork6=external-net01
In this case, when the vApp template is deployed into vdc1, the vApp network named net01
would be joined to the vDC network named internal-net01-vdc1 and the vApp network named
net03 would be joined to the vDC network named external-net01-vdc1, while the vApp network
named net02 would not be bridged. Similarly, if the vApp template is deployed into vdc2, then
the vApp network named net01 would be joined to the vDC network named internal-net01-vdc2
and the vApp network named net03 would be joined to the vDC network named external-net01vdc2, while the vApp network named net02 would not be bridged.
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